summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-futures_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:06 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit3dd375570e0c1bc3a94d1d821946c511b17b1382 (patch)
tree02df0ad801228de173b3ca88ac5862c7e5d9d3f0 /meta-openstack/recipes-devtools/python/python-futures_git.bb
parentac446f3bc8a6df622f3551952f055064847f6f0e (diff)
downloadmeta-cloud-services-3dd375570e0c1bc3a94d1d821946c511b17b1382.tar.gz
python-*: uprev to versions required for liberty
This is a collection of recipe uprevs that bring various packages up to the version required to support the liberty release. These uprevs are mostly trivial with the expected SRC_URI and CHECKSUM updates along with updates to the list of dependencies. Where possible recipes have been updated to use git to facilitate future uprevs. For python-futures we need to add a PREFERRED_VERSION to ensure the git version will take precedence over a versioned recipe found in another layer. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-futures_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-futures_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-futures_git.bb b/meta-openstack/recipes-devtools/python/python-futures_git.bb
new file mode 100644
index 0000000..f26be9a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-futures_git.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Backport of the concurrent.futures package from Python 3.2"
2HOMEPAGE = "https://github.com/agronholm/pythonfutures"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dd6708d05936d3f6c4e20ed14c87b5e3"
6
7PV = "3.0.3+git${SRCPV}"
8SRCREV = "6532a7449d8102c172ea5011f1552fcc163c09f1"
9
10SRCNAME = "futures"
11SRC_URI = "git://github.com/agronholm/python${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 python-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "