summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-functools32_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-11 21:50:31 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-11-16 15:11:44 -0500
commit464924c6e56227918f4a52f3214efe52e823be39 (patch)
tree621bd2f3841b06febeeb44fc9ee2e54e9af91545 /meta-openstack/recipes-devtools/python/python-functools32_git.bb
parentafc3c449378134e0ede5cb1bdbfc431dbc4abe58 (diff)
downloadmeta-cloud-services-464924c6e56227918f4a52f3214efe52e823be39.tar.gz
functools32: use git instead of release tarballs
Since we are often moving packages forward on the master branch it is simpler to use git instead of tarballs. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-functools32_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-functools32_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-functools32_git.bb b/meta-openstack/recipes-devtools/python/python-functools32_git.bb
new file mode 100644
index 0000000..f167e7d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-functools32_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Python higher-order functions and operations on callable objects"
2HOMEPAGE = "https://pypi.python.org/pypi/functools32"
3SECTION = "devel/python"
4LICENSE = "PSFv2"
5
6PV = "3.2.3-2"
7SRCREV = "ad90fa86e2f4f494a3aedb0571274f3bbc6d7ab5"
8
9SRCNAME = "functools32"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=27cf2345969ed18e6730e90fb0063a10"
12SRC_URI = "git://github.com/MiCHiLU/python-${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
15
16inherit distutils
17
18DISTUTILS_INSTALL_ARGS = "--root=${D} \
19 --prefix=${prefix} \
20 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
21 --install-data=${datadir}"
22
23DEPENDS += " \
24 python-pbr \
25 "
26
27RDEPENDS_${PN} += "python-testtools \
28 python-pbr \
29 "
30