summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-08-06 16:11:55 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-08-10 09:48:17 -0400
commit540c2e41a95545df6f7e00de9461f1393070058e (patch)
tree50c1c0fb4acbdb4c71034d5e3496dd44a3bb06b4 /meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
parent7f56afd14ccacb8ea52e7ca0822c86cdba5bea0f (diff)
downloadmeta-cloud-services-540c2e41a95545df6f7e00de9461f1393070058e.tar.gz
python-fixtures: upgrade 1.0.0 -> 1.3.1
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb b/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
new file mode 100644
index 0000000..f8f7163
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Fixtures, reusable state for writing clean tests and more"
2HOMEPAGE = "https://pypi.python.org/pypi/fixtures/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=239e2f4698b85aad5ed39bae5d2ef226"
6
7PR = "r0"
8SRCNAME = "fixtures"
9
10SRC_URI = "https://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "72959be66e26b09641a1e3902f631e62"
13SRC_URI[sha256sum] = "b63cf3bb37f83ff815456e2d0e118535ae9a4bf43e76d9a1cf3286041bf717ce"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19DISTUTILS_INSTALL_ARGS = "--root=${D} \
20 --prefix=${prefix} \
21 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
22 --install-data=${datadir}"
23
24RDEPENDS_${PN} += "python-testtools"