summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-03 22:56:57 -0400
commit3b9fa62452c636c49cc1bd19436e37882c76b88c (patch)
tree3fc5e422f733d9e037f387638a459eeaeecbab61 /meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
parenta8dbfb290b485d41da1bea5dd37907db684d86fc (diff)
downloadmeta-cloud-services-3b9fa62452c636c49cc1bd19436e37882c76b88c.tar.gz
clients: add bash-completion support
Package and enable the bash completion suppor that comes with the various client packages. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinderclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index 3c7293b..1f4e4a6 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -30,3 +30,14 @@ RDEPENDS_${PN} += "python-prettytable \
30 python-setuptools-git \ 30 python-setuptools-git \
31 python-pbr \ 31 python-pbr \
32 " 32 "
33
34PACKAGECONFIG ?= "bash-completion"
35PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
36
37do_install_append() {
38 install -d ${D}/${sysconfdir}/bash_completion.d
39 install -m 664 ${S}/tools/cinder.bash_completion ${D}/${sysconfdir}/bash_completion.d
40}
41
42PACKAGES =+ "${BPN}-bash-completion"
43FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"