summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2015-12-09 13:40:19 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:14:32 -0500
commit2d260e08c1e1b4f115b226fdcaf02eb9e7dce77f (patch)
treeddce110fd984835924f46b12ad0cdba01268158f /meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
parent464924c6e56227918f4a52f3214efe52e823be39 (diff)
downloadmeta-cloud-services-2d260e08c1e1b4f115b226fdcaf02eb9e7dce77f.tar.gz
Use a bbclass to remove argparse from requirements
argparse is required by some of the CLI applications of openstack. The module is provided by python 2.7, however python-distribute (used in fido), is not able to find it: Python 2.7.9 (default, Oct 27 2015, 18:12:55) [GCC 4.9.2] on linux2 Type "help", "copyright", "credits" or "license" for more information. >>> import pkg_resources >>> pkg_resources.get_distribution('argparse') Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib/python2.7/site-packages/distribute-0.6.49-py2.7.egg/pkg_resources.py", line 338, in get_distribution if isinstance(dist,Requirement): dist = get_provider(dist) File "/usr/lib/python2.7/site-packages/distribute-0.6.49-py2.7.egg/pkg_resources.py", line 217, in get_provider return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0] File "/usr/lib/python2.7/site-packages/distribute-0.6.49-py2.7.egg/pkg_resources.py", line 698, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python2.7/site-packages/distribute-0.6.49-py2.7.egg/pkg_resources.py", line 596, in resolve raise DistributionNotFound(req) pkg_resources.DistributionNotFound: argparse >>> import argparse >>> This patch adds a class that when inherited will remove argparse from requirements.txt. Also with this patch, those python modules used by openstackclient inherit the class. Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinderclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index 31875fa..7e8e780 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -18,7 +18,7 @@ PV="1.1.1+git${SRCPV}"
18SRCREV="9e94d814c6ae07c3d5e8242754aebcce150265cc" 18SRCREV="9e94d814c6ae07c3d5e8242754aebcce150265cc"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit setuptools monitor 21inherit setuptools monitor rmargparse
22 22
23DEPENDS += " \ 23DEPENDS += " \
24 python-pip \ 24 python-pip \