summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 01:28:40 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:35 -0500
commit2290ee09ef3c2cd8aaf7fe3dc40bf22eb842b3f4 (patch)
tree119cce29fb8c39a1f6a7fcfc1ac7c9828d1e3a74 /meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
parentf6a3429956683bd19aa9bdfa05da3cb57451ce2c (diff)
downloadmeta-cloud-services-2290ee09ef3c2cd8aaf7fe3dc40bf22eb842b3f4.tar.gz
cinder: uprev to havana release
Updating the cinder block storage component to the havana release. At the same time, we switch to a git based build. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinderclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
new file mode 100644
index 0000000..b9a353d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Client library for OpenStack Cinder API."
2HOMEPAGE = "https://github.com/openstack/python-cinderclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3572962e13e5e739b30b0864365e0795"
6DEPENDS = "python-setuptools-git"
7
8PR = "r0"
9SRCNAME = "python-cinderclient"
10
11SRC_URI = "git://github.com/openstack/python-cinderclient.git;branch=master"
12
13PV="git${SRCPV}"
14SRCREV="bdd560b3c02ea0a013ed4b7e7641c6240f3b602f"
15S = "${WORKDIR}/git"
16
17inherit setuptools
18
19RDEPENDS_${PN} += "python-prettytable \
20 python-simplejson \
21 python-requests \
22 python-setuptools-git \
23 "