summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinder_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 15:07:17 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 15:07:17 -0500
commit8e8bcf786654231916f85b45aa32a56dae222f71 (patch)
tree61f6c6580a45d3a2b801b7ff25d282173bf23a59 /meta-openstack/recipes-devtools/python/python-cinder_git.bb
parent393b57ed6d6d7c79d400714aa3d6a81023e4c424 (diff)
downloadmeta-cloud-services-8e8bcf786654231916f85b45aa32a56dae222f71.tar.gz
cinder: modify run_tests to respect --tools-dir
Since the "tools" subdir of cinder is only packaged and installed in /etc/cinder, we need to use --tools-dir to point the test script in the right direction. Unfortunately, run_tests.sh takes this arg and ignores it. So we patch the script to actually respect the directory. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinder_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 50eacaa..c441828 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -11,6 +11,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
11 file://cinder.conf \ 11 file://cinder.conf \
12 file://cinder.init \ 12 file://cinder.init \
13 file://cinder-volume \ 13 file://cinder-volume \
14 file://0001-run_tests-respect-tools-dir.patch \
14 " 15 "
15 16
16SRCREV="1f99a044580286bf0d927cc7fc7ce3378653aef0" 17SRCREV="1f99a044580286bf0d927cc7fc7ce3378653aef0"
@@ -48,7 +49,9 @@ do_install_append() {
48 install -m 0755 ${WORKDIR}/cinder-volume ${D}${sysconfdir}/init.d/cinder-volume 49 install -m 0755 ${WORKDIR}/cinder-volume ${D}${sysconfdir}/init.d/cinder-volume
49 fi 50 fi
50 51
52 # test setup
51 cp run_tests.sh ${CINDER_CONF_DIR} 53 cp run_tests.sh ${CINDER_CONF_DIR}
54 cp -r tools ${CINDER_CONF_DIR}
52} 55}
53 56
54pkg_postinst_${SRCNAME}-setup () { 57pkg_postinst_${SRCNAME}-setup () {
@@ -75,7 +78,8 @@ ALLOW_EMPTY_${SRCNAME}-setup = "1"
75 78
76FILES_${PN} = "${libdir}/*" 79FILES_${PN} = "${libdir}/*"
77 80
78FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 81FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh \
82 ${sysconfdir}/${SRCNAME}/tools"
79 83
80FILES_${SRCNAME}-api = "${bindir}/cinder-api \ 84FILES_${SRCNAME}-api = "${bindir}/cinder-api \
81 ${sysconfdir}/init.d/cinder-api" 85 ${sysconfdir}/init.d/cinder-api"