summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinder_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-05-07 14:34:19 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-07 14:34:19 -0400
commit59a83fa1d29006720d871285c857920fe4f9e68b (patch)
tree96b0593902f68d15efc886e0d1bfb0812077ae31 /meta-openstack/recipes-devtools/python/python-cinder_git.bb
parent65c5c2fdcdfd6810247c35e33342a40e3b2c4d0d (diff)
downloadmeta-cloud-services-59a83fa1d29006720d871285c857920fe4f9e68b.tar.gz
cinder: add keyston auth section
To avoid SSL default communications, and quota/volume errors, we expicitly add a keystone configuration section to the cinder configuration. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinder_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 0239406..f14102e 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -40,6 +40,9 @@ do_install_append() {
40 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${WORKDIR}/cinder.conf 40 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${WORKDIR}/cinder.conf
41 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${WORKDIR}/cinder.conf 41 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${WORKDIR}/cinder.conf
42 sed -e "s:%CINDER_BACKUP_BACKEND_DRIVER%:${CINDER_BACKUP_BACKEND_DRIVER}:g" -i ${WORKDIR}/cinder.conf 42 sed -e "s:%CINDER_BACKUP_BACKEND_DRIVER%:${CINDER_BACKUP_BACKEND_DRIVER}:g" -i ${WORKDIR}/cinder.conf
43 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${WORKDIR}/cinder.conf
44 sed -e "s:%SERVICE_USER%:${SRCNAME}:g" -i ${WORKDIR}/cinder.conf
45 sed -e "s:%SERVICE_PASSWORD%:${SERVICE_PASSWORD}:g" -i ${WORKDIR}/cinder.conf
43 46
44 install -d ${CINDER_CONF_DIR} 47 install -d ${CINDER_CONF_DIR}
45 install -m 600 ${WORKDIR}/cinder.conf ${CINDER_CONF_DIR}/ 48 install -m 600 ${WORKDIR}/cinder.conf ${CINDER_CONF_DIR}/