summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinder_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-02-28 09:11:14 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 14:24:31 -0400
commit1e2599e4801c1acd16ea61a533d95bbd7a808a54 (patch)
treeab8dcc3b2c4869fc74366661de1d346d34ff65d2 /meta-openstack/recipes-devtools/python/python-cinder_git.bb
parente617d0205fc566ef70b61a75c484d78c540ef791 (diff)
downloadmeta-cloud-services-1e2599e4801c1acd16ea61a533d95bbd7a808a54.tar.gz
cinder-volume: change lvm pv to be configured at runtime
By default lvm-iscsi uses loopdev as lvm physical volume. This patch makes it a bit easier to allow other layer to be able configure lvm physical volume. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinder_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index c2479f7..e03b54f 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
14 file://0001-run_tests-respect-tools-dir.patch \ 14 file://0001-run_tests-respect-tools-dir.patch \
15 file://nfs_setup.sh \ 15 file://nfs_setup.sh \
16 file://glusterfs_setup.sh \ 16 file://glusterfs_setup.sh \
17 file://lvm_iscsi_setup.sh \
17 " 18 "
18 19
19SRCREV="8b5fb8409322f61d8b610c97c109a61bf48a940e" 20SRCREV="8b5fb8409322f61d8b610c97c109a61bf48a940e"
@@ -43,6 +44,7 @@ do_install_append() {
43 install -d ${CINDER_CONF_DIR}/drivers 44 install -d ${CINDER_CONF_DIR}/drivers
44 install -m 600 ${WORKDIR}/nfs_setup.sh ${CINDER_CONF_DIR}/drivers/ 45 install -m 600 ${WORKDIR}/nfs_setup.sh ${CINDER_CONF_DIR}/drivers/
45 install -m 600 ${WORKDIR}/glusterfs_setup.sh ${CINDER_CONF_DIR}/drivers/ 46 install -m 600 ${WORKDIR}/glusterfs_setup.sh ${CINDER_CONF_DIR}/drivers/
47 install -m 600 ${WORKDIR}/lvm_iscsi_setup.sh ${CINDER_CONF_DIR}/drivers/
46 48
47 install -d ${D}${localstatedir}/log/${SRCNAME} 49 install -d ${D}${localstatedir}/log/${SRCNAME}
48 50
@@ -81,7 +83,7 @@ pkg_postinst_${SRCNAME}-setup () {
81 cinder-manage db sync 83 cinder-manage db sync
82 84
83 #Create cinder volume group backing file 85 #Create cinder volume group backing file
84 [[ -f /etc/cinder/volumes-backing ]] || truncate -s ${CINDER_LVM_VOLUME_BACKING_FILE_SIZE} /etc/cinder/volumes-backing 86 sed 's/%CINDER_LVM_VOLUME_BACKING_FILE_SIZE%/${CINDER_LVM_VOLUME_BACKING_FILE_SIZE}/g' -i /etc/cinder/drivers/lvm_iscsi_setup.sh
85 echo "include /etc/cinder/data/volumes/*" >> /etc/tgt/targets.conf 87 echo "include /etc/cinder/data/volumes/*" >> /etc/tgt/targets.conf
86 88
87 # Create Cinder nfs_share config file with default nfs server 89 # Create Cinder nfs_share config file with default nfs server