summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-04-15 13:58:28 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-04-16 15:12:22 -0400
commit10614d4b5deb627f17735fda08448ef5ae02d5a0 (patch)
tree43b7b65130d772668699c655099c4ea4e26a5c67 /meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
parent4a6d0a7e0975bb18434a392b6d1d319ead1e97d0 (diff)
downloadmeta-cloud-services-10614d4b5deb627f17735fda08448ef5ae02d5a0.tar.gz
python-cephclient: upgrade to 0.1.0.5
Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb b/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
new file mode 100644
index 0000000..ad55514
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "A client library in python for the Ceph REST API."
2HOMEPAGE = "https://github.com/dmsimard/python-cephclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7PR = "r0"
8
9SRCNAME = "python-cephclient"
10SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-v${PV}.tar.gz"
11
12SRC_URI[md5sum] = "e3746607f1af1573a241b4995c10c938"
13SRC_URI[sha256sum] = "9776b786da2aebdc0439ea2f809cc8923f52bc0cf610f77a9c1348466961134b"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 python-lxml \
28 python-requests \
29 python-cython \
30 "