summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-02-28 09:11:13 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 14:24:31 -0400
commite617d0205fc566ef70b61a75c484d78c540ef791 (patch)
treec5969046b73ea732f01c692ddfeef599ecb00eeb /meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
parent2c14cdfb9c34c541a1b3a180ad2a625514300977 (diff)
downloadmeta-cloud-services-e617d0205fc566ef70b61a75c484d78c540ef791.tar.gz
Readjust the start level of openstack components
Currently all the openstack components have default start level of 20. There are other services such as glusterfs, rabbbitmq, database... are also starting at the same start level. On some platform, this can cause racing condition between services which in turn causes some of openstack components not started. By adjusting the openstack components start level to higher will ensure that system services start in the determistic way. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometer_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index e67f2bf..7d1796d 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -90,7 +90,7 @@ pkg_postinst_${SRCNAME}-setup () {
90 ceilometer-dbsync 90 ceilometer-dbsync
91} 91}
92 92
93inherit setuptools identity hosts update-rc.d 93inherit setuptools identity hosts update-rc.d default_configs
94 94
95PACKAGES += " ${SRCNAME}-tests" 95PACKAGES += " ${SRCNAME}-tests"
96PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api" 96PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api"
@@ -193,8 +193,14 @@ RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-controller"
193INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller" 193INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller"
194INITSCRIPT_PACKAGES += "${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator" 194INITSCRIPT_PACKAGES += "${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator"
195INITSCRIPT_NAME_${SRCNAME}-api = "${SRCNAME}-api" 195INITSCRIPT_NAME_${SRCNAME}-api = "${SRCNAME}-api"
196INITSCRIPT_PARAMS_${SRCNAME}-api = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
196INITSCRIPT_NAME_${SRCNAME}-collector = "${SRCNAME}-collector" 197INITSCRIPT_NAME_${SRCNAME}-collector = "${SRCNAME}-collector"
198INITSCRIPT_PARAMS_${SRCNAME}-collector = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
197INITSCRIPT_NAME_${SRCNAME}-compute = "${SRCNAME}-agent-compute" 199INITSCRIPT_NAME_${SRCNAME}-compute = "${SRCNAME}-agent-compute"
200INITSCRIPT_PARAMS_${SRCNAME}-compute = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
198INITSCRIPT_NAME_${SRCNAME}-controller = "${SRCNAME}-agent-central" 201INITSCRIPT_NAME_${SRCNAME}-controller = "${SRCNAME}-agent-central"
202INITSCRIPT_PARAMS_${SRCNAME}-controller = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
199INITSCRIPT_NAME_${SRCNAME}-alarm-notifier = "${SRCNAME}-alarm-notifier" 203INITSCRIPT_NAME_${SRCNAME}-alarm-notifier = "${SRCNAME}-alarm-notifier"
204INITSCRIPT_PARAMS_${SRCNAME}-alarm-notifier = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
200INITSCRIPT_NAME_${SRCNAME}-alarm-evaluator = "${SRCNAME}-alarm-evaluator" 205INITSCRIPT_NAME_${SRCNAME}-alarm-evaluator = "${SRCNAME}-alarm-evaluator"
206INITSCRIPT_PARAMS_${SRCNAME}-alarm-evaluator = "${OS_DEFAULT_INITSCRIPT_PARAMS}"