summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-03-17 12:25:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 13:12:55 -0400
commitd370e70c089c06241a739b47916a5c6d6c37226b (patch)
tree7241f47e4871abf9bb23011aadea5826fa217542 /meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
parent54c9a71b7f00c7dd35ecff6aad86cd47d83280d6 (diff)
downloadmeta-cloud-services-d370e70c089c06241a739b47916a5c6d6c37226b.tar.gz
python-*: prevent setuptools from fetching required eggs
Several python packages require 'python-pbr' both at build and runtime, as listed in their respective setup.py files, yet this dependency is not included in their recipe. Adding python-pbr to the RDEPENDS to correct this. In addition this situation is complicated by the fact that the setuptools will actually fetch python-pip and python-pbr eggs, regardless of the value of BB_NO_NETWORK, if any of these packages are built before python-pip and python-pbr are in the sysroot. Most dramitically if you were to attempt to build any of these packages with no network connectivity the do_compile() task will fail with the following: | DEBUG: Executing shell function do_compile | Download error: [Errno 110] Connection timed out -- Some packages may not be found! | Couldn't find index page for 'pip' (maybe misspelled?) | Download error: [Errno 110] Connection timed out -- Some packages may not be found! | No local packages or download links found for pip>=1.0 | Traceback (most recent call last): | File "setup.py", line 21, in <module> | pbr=True) Adding the missing DEPENDS will ensure these packages are available without the need for setuptools to fetch them, and avoid possible build issues due to network connectivity. In order to test these modifications all of these packages have been built with a populated sstate cache and the network crippled using: iptables -A OUTPUT -p tcp --destination-port 80 -j DROP to ensure no extra fetches are taking place. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometer_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index cf0d196..e67f2bf 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -131,6 +131,11 @@ FILES_${SRCNAME}-controller = "${bindir}/* \
131 ${sysconfdir}/init.d/ceilometer-agent-central \ 131 ${sysconfdir}/init.d/ceilometer-agent-central \
132" 132"
133 133
134DEPENDS += " \
135 python-pip \
136 python-pbr \
137 "
138
134RDEPENDS_${PN} += " \ 139RDEPENDS_${PN} += " \
135 python-ply \ 140 python-ply \
136 python-jsonpath-rw \ 141 python-jsonpath-rw \
@@ -175,6 +180,7 @@ RDEPENDS_${PN} += " \
175 python-pyyaml \ 180 python-pyyaml \
176 python-pip \ 181 python-pip \
177 python-pytz \ 182 python-pytz \
183 python-pbr \
178 " 184 "
179 185
180RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator \ 186RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator \