summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-09-30 12:22:12 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-30 14:30:18 -0400
commitb4d666ff63acd269b0acb2c4419643863c683750 (patch)
treef22e20ee845a0cca1fe0f7837d92a652325ba036 /meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
parent1b8a298689a95c1943f18d8d9c24589e64bbc7b7 (diff)
downloadmeta-cloud-services-b4d666ff63acd269b0acb2c4419643863c683750.tar.gz
add generic monitor framework
Instead of having a central file or group of files to describe what data resources should be monitored. The content of these files will depend on what core system monitoring is used ((e.g. Nagios or Monasca). It's desirable to have each recipe describes what it wants be monitored in generic way such that various system monitors can understand and convert these into their format. If a recipe wishes to register itself to system monitor, it inherits monitor bbclass and use MONITOR_SERVICE_PACKAGES and MONITOR_SERVICE_<package name> to indicate what processes should should be monitored. Also MONITOR_CHECKS_<package name> variale can be used to pass list of scripts which will be run on target and if any of these scripts fail then will report. Eventually monitor.bbclass will be expanded to allow recipe to describe more complicated information passed down to system monitor (e.g. Nagios or Monasca) Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometer_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index d12715d..90ac1c6 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -127,7 +127,7 @@ pkg_postinst_${SRCNAME}-setup () {
127 ceilometer-dbsync 127 ceilometer-dbsync
128} 128}
129 129
130inherit setuptools identity hosts update-rc.d default_configs openstackchef 130inherit setuptools identity hosts update-rc.d default_configs openstackchef monitor
131 131
132PACKAGES += " ${SRCNAME}-tests" 132PACKAGES += " ${SRCNAME}-tests"
133PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api" 133PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api"
@@ -257,3 +257,6 @@ INITSCRIPT_NAME_${SRCNAME}-alarm-evaluator = "${SRCNAME}-alarm-evaluator"
257INITSCRIPT_PARAMS_${SRCNAME}-alarm-evaluator = "${OS_DEFAULT_INITSCRIPT_PARAMS}" 257INITSCRIPT_PARAMS_${SRCNAME}-alarm-evaluator = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
258INITSCRIPT_NAME_${SRCNAME}-agent-notification = "${SRCNAME}-agent-notification" 258INITSCRIPT_NAME_${SRCNAME}-agent-notification = "${SRCNAME}-agent-notification"
259INITSCRIPT_PARAMS_${SRCNAME}-agent-notification = "${OS_DEFAULT_INITSCRIPT_PARAMS}" 259INITSCRIPT_PARAMS_${SRCNAME}-agent-notification = "${OS_DEFAULT_INITSCRIPT_PARAMS}"
260
261MONITOR_SERVICE_PACKAGES = "${SRCNAME}"
262MONITOR_SERVICE_${SRCNAME} = "ceilometer"