summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-01-30 16:50:10 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-01-30 16:50:10 -0500
commit52630db08636fb2ceb985ee4651e7d5b9032948c (patch)
tree03f846e2b2add3f6ee2179d6d38eb1eda5d68417 /meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
parenta6ff9ee05cccceb92c422319727b50c292bf1aea (diff)
downloadmeta-cloud-services-52630db08636fb2ceb985ee4651e7d5b9032948c.tar.gz
ceilometer: uprev to 2014.1.x release
The havana ceilometer postgres (sqlalchemy) support has significant issues. Rather that perform signficicant backports, we'll uprev and pick up the latest development stream, that addresses many issues out of the box. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometer_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb20
1 files changed, 13 insertions, 7 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 41fae5e..cf0d196 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -7,20 +7,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7PR = "r0" 7PR = "r0"
8SRCNAME = "ceilometer" 8SRCNAME = "ceilometer"
9 9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://ceilometer.conf \ 11 file://ceilometer.conf \
12 file://ceilometer.init \ 12 file://ceilometer.init \
13 file://0001-Fix-for-get_resources-with-postgresql.patch \ 13 file://0001-sqlalchemy-Fix-for-get_statistics-with-postgresql.patch \
14 file://0002-enable-sql-metadata-query.patch \
15 file://sqlalchemy-fix-ceilometer-resource-query.patch \
16" 14"
17 15
18SRCREV="ef71dc6a11ab624e756bfb61ec974e9f6096bc30" 16SRCREV="a4c7411ac903984c7e7524469f89a417cf9cf97e"
19PV="2013.2.2+git${SRCPV}" 17PV="2014.1.b2+git${SRCPV}"
20S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
21 19
22CEILOMETER_SECRET ?= "12121212" 20CEILOMETER_SECRET ?= "12121212"
23 21
22do_configure_append() {
23 # We are using postgresql support, hence this requirement is not valid
24 # removing it, to avoid on-target runtime issues
25 sed -e "s:MySQL-python::g" -i ${S}/requirements.txt
26}
27
24do_install_append() { 28do_install_append() {
25 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME} 29 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
26 CEILOMETER_CONF_DIR=${D}${sysconfdir}/${SRCNAME} 30 CEILOMETER_CONF_DIR=${D}${sysconfdir}/${SRCNAME}
@@ -128,7 +132,9 @@ FILES_${SRCNAME}-controller = "${bindir}/* \
128" 132"
129 133
130RDEPENDS_${PN} += " \ 134RDEPENDS_${PN} += " \
131 python-sqlalchemy \ 135 python-ply \
136 python-jsonpath-rw \
137 python-sqlalchemy \
132 python-amqplib \ 138 python-amqplib \
133 python-anyjson \ 139 python-anyjson \
134 python-eventlet \ 140 python-eventlet \