summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 15:58:06 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 15:58:06 -0500
commit4b934fe1b660757fe74aeb9e5e528c3a1631c18d (patch)
tree14cddc8889979facc77e10dabaecbff385cb5cc1 /meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
parent0a1667f836616d86b1c04c3e70ecf5c8e4f3a4ef (diff)
downloadmeta-cloud-services-4b934fe1b660757fe74aeb9e5e528c3a1631c18d.tar.gz
ceilometer: add -tests package to deploy run_tests.sh on target
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometer_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 70f9166..436bdbc 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -56,6 +56,8 @@ do_install_append() {
56 sed 's:@suffix@:agent-compute:' < ${WORKDIR}/ceilometer.init >${WORKDIR}/ceilometer-agent-compute.init.sh 56 sed 's:@suffix@:agent-compute:' < ${WORKDIR}/ceilometer.init >${WORKDIR}/ceilometer-agent-compute.init.sh
57 install -m 0755 ${WORKDIR}/ceilometer-agent-compute.init.sh ${D}${sysconfdir}/init.d/ceilometer-agent-compute 57 install -m 0755 ${WORKDIR}/ceilometer-agent-compute.init.sh ${D}${sysconfdir}/init.d/ceilometer-agent-compute
58 fi 58 fi
59
60 cp run-tests.sh ${CEILOMETER_CONF_DIR}
59} 61}
60 62
61pkg_postinst_${SRCNAME}-setup () { 63pkg_postinst_${SRCNAME}-setup () {
@@ -77,12 +79,15 @@ pkg_postinst_${SRCNAME}-setup () {
77 79
78inherit setuptools identity hosts update-rc.d 80inherit setuptools identity hosts update-rc.d
79 81
82PACKAGES += " ${SRCNAME}-tests"
80PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller" 83PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller"
81 84
82ALLOW_EMPTY_${SRCNAME}-setup = "1" 85ALLOW_EMPTY_${SRCNAME}-setup = "1"
83 86
84FILES_${PN} = "${libdir}/*" 87FILES_${PN} = "${libdir}/*"
85 88
89FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run-tests.sh"
90
86FILES_${SRCNAME}-common = "${sysconfdir}/${SRCNAME}/* \ 91FILES_${SRCNAME}-common = "${sysconfdir}/${SRCNAME}/* \
87" 92"
88 93