summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
diff options
context:
space:
mode:
authorAndy Ning <andy.ning@windriver.com>2014-07-16 11:37:37 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-30 00:50:59 -0400
commit0aec82d70fa032bfe616ea5058d504f860e241f8 (patch)
treecd88ce4f6c7ac88308b85d1ce66941877978cc51 /meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
parentceecd0d46de35111f4c3c1e65176e09cb2117ecb (diff)
downloadmeta-cloud-services-0aec82d70fa032bfe616ea5058d504f860e241f8.tar.gz
Keystone: package service/user additions
Instead of creating tenant/user/role and service/endpoint for all openstack services in keystone postinstall, now each of the services creates its own keystone identities by queueing them up in its postinstall to a file /etc/keystone/service-user-setup. service-user-setup script, when run as the last postinstall, calls identity.sh with keystone identity parameters to create necessary identities for the services. Signed-off-by: Andy Ning <andy.ning@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ceilometer_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb31
1 files changed, 30 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 1e6e200..ad35de2 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -20,6 +20,32 @@ S = "${WORKDIR}/git"
20 20
21CEILOMETER_SECRET ?= "12121212" 21CEILOMETER_SECRET ?= "12121212"
22 22
23SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-reseller"
24KEYSTONE_HOST="${CONTROLLER_IP}"
25
26# USERCREATE_PARAM and SERVICECREATE_PARAM contain the list of parameters to be set.
27# If the flag for a parameter in the list is not set here, the default value will be given to that parameter.
28# Parameters not in the list will be set to empty.
29
30USERCREATE_PARAM_${SRCNAME}-setup = "name pass tenant role email"
31SERVICECREATE_PARAM_${SRCNAME}-setup = "name type description region publicurl adminurl internalurl"
32python () {
33 flags = {'type':'metering',\
34 'description':'OpenStack Metering Service',\
35 'publicurl':"'http://${KEYSTONE_HOST}:8777/'",\
36 'adminurl':"'http://${KEYSTONE_HOST}:8777/'",\
37 'internalurl':"'http://${KEYSTONE_HOST}:8777/'"}
38
39 d.setVarFlags("SERVICECREATE_PARAM_%s-setup" % d.getVar('SRCNAME',True), flags)
40}
41
42# Add service user to service tenant as ResellerAdmin role
43USERCREATE_PARAM_${SRCNAME}-reseller = "name pass tenant role email"
44python () {
45 flags = {'role':'ResellerAdmin'}
46 d.setVarFlags("USERCREATE_PARAM_%s-reseller" % d.getVar('SRCNAME',True), flags)
47}
48
23do_configure_append() { 49do_configure_append() {
24 # We are using postgresql support, hence this requirement is not valid 50 # We are using postgresql support, hence this requirement is not valid
25 # removing it, to avoid on-target runtime issues 51 # removing it, to avoid on-target runtime issues
@@ -103,8 +129,10 @@ PACKAGES += "${SRCNAME}-setup ${SRCNAME}-common ${SRCNAME}-api"
103PACKAGES += "${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator" 129PACKAGES += "${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator"
104PACKAGES += "${SRCNAME}-agent-notification" 130PACKAGES += "${SRCNAME}-agent-notification"
105PACKAGES += "${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller" 131PACKAGES += "${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller"
132PACKAGES += " ${SRCNAME}-reseller"
106 133
107ALLOW_EMPTY_${SRCNAME}-setup = "1" 134ALLOW_EMPTY_${SRCNAME}-setup = "1"
135ALLOW_EMPTY_${SRCNAME}-reseller = "1"
108 136
109FILES_${PN} = "${libdir}/*" 137FILES_${PN} = "${libdir}/*"
110 138
@@ -198,12 +226,13 @@ RDEPENDS_${PN} += " \
198 python-pysnmp \ 226 python-pysnmp \
199 " 227 "
200 228
201RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator ${SRCNAME}-agent-notification \ 229RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator ${SRCNAME}-agent-notification ${SRCNAME}-reseller \
202 postgresql postgresql-client python-psycopg2 tgt" 230 postgresql postgresql-client python-psycopg2 tgt"
203RDEPENDS_${SRCNAME}-api = "${SRCNAME}-controller" 231RDEPENDS_${SRCNAME}-api = "${SRCNAME}-controller"
204RDEPENDS_${SRCNAME}-collector = "${SRCNAME}-controller" 232RDEPENDS_${SRCNAME}-collector = "${SRCNAME}-controller"
205RDEPENDS_${SRCNAME}-compute = "${PN} ${SRCNAME}-common python-ceilometerclient libvirt" 233RDEPENDS_${SRCNAME}-compute = "${PN} ${SRCNAME}-common python-ceilometerclient libvirt"
206RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-controller" 234RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-controller"
235RDEPENDS_${SRCNAME}-reseller = "postgresql sudo ${SRCNAME}-controller"
207 236
208INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller" 237INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller"
209INITSCRIPT_PACKAGES += "${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator ${SRCNAME}-agent-notification" 238INITSCRIPT_PACKAGES += "${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator ${SRCNAME}-agent-notification"