summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-barbican_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-15 12:59:53 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-15 15:53:38 -0500
commit3051160f23fe8e06e545859538c86ef3a3c39d7a (patch)
tree97f922e30173df31dda04f10cca3beea27652eb8 /meta-openstack/recipes-devtools/python/python-barbican_git.bb
parent3d512115129e2cea97067d23cb72fea62b70dd39 (diff)
downloadmeta-cloud-services-3051160f23fe8e06e545859538c86ef3a3c39d7a.tar.gz
python-*: fixup postinst scripts
Checking for "$D" and doing an "exit 1" now results in errors such as: [log_check] warning: %post(keystone-cronjobs-...) scriptlet failed, exit status 2 during image creation. Instead of escaping the script for "level-1" (image creation postinst) we wrap the "level-2" (first boot) postinst in an if statement. This also ensure the scriptlet in indentity.bbclass is less prone to behaving differently based on the postinsts defined in the classes which inherit 'identity'. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-barbican_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index 0b3d768..579413c 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -85,12 +85,10 @@ FILES_${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \
85 85
86ALLOW_EMPTY_${SRCNAME}-setup = "1" 86ALLOW_EMPTY_${SRCNAME}-setup = "1"
87pkg_postinst_${SRCNAME}-setup () { 87pkg_postinst_${SRCNAME}-setup () {
88 if [ "x$D" != "x" ]; then 88 if [ -z "$D" ]; then
89 exit 1 89 chown -R barbican:barbican ${sysconfdir}/${SRCNAME}
90 chown -R barbican:barbican ${localstatedir}/lib/barbican
90 fi 91 fi
91
92 chown -R barbican:barbican ${sysconfdir}/${SRCNAME}
93 chown -R barbican:barbican ${localstatedir}/lib/barbican
94} 92}
95 93
96DEPENDS += " \ 94DEPENDS += " \