summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:15 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit53e2faa09a03ece3c30f94ba652dd69a9334884f (patch)
tree456609d2c61813df49fc4015f13d8997d7bfa61b /meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb
parentaee7381269b29cf8508f6708fb9985ed9cf95814 (diff)
downloadmeta-cloud-services-53e2faa09a03ece3c30f94ba652dd69a9334884f.tar.gz
python-aioeventlet: initial version
This package provides asyncio event loop scheduling callbacks in eventlet. This package is required by oslo.messaging. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb b/meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb
new file mode 100644
index 0000000..0841b9b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-aioeventlet_0.4.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Asyncio event loop scheduling callbacks in eventlet"
2HOMEPAGE = "http://aioeventlet.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8f7bb094c7232b058c7e9f2e431f389c"
6
7SRCNAME = "aioeventlet"
8
9SRC_URI = "https://pypi.python.org/packages/source/a/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10 file://Makefile-skip-building-docs.patch \
11 "
12
13SRC_URI[md5sum] = "678ea30265ae0326bddc767f80efd144"
14SRC_URI[sha256sum] = "fe78c2b227ce077b1581e2ae2c071f351111d0878ec1b0216435f6a898df79a6"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools
19
20DEPENDS += " \
21 python-pip \
22 "
23
24RDEPENDS_${PN} += " \
25 python-sphinx \
26 "
27