summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/erlang
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2013-11-20 18:38:35 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-26 12:13:22 -0500
commit5d3042a0ba2d7e66c434b6ba545a943c184dcf7f (patch)
tree55cdb10b35de56fcb45561fbc98f0856f6a25f00 /meta-openstack/recipes-devtools/erlang
parentdf8f601c6d07e3cedd5542a4648cf79280fe06fe (diff)
downloadmeta-cloud-services-5d3042a0ba2d7e66c434b6ba545a943c184dcf7f.tar.gz
erlang: skip the host library path check to fix cross-compile issue
Below is the error message: ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities. Rerun configure task after fixing this. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/erlang')
-rw-r--r--meta-openstack/recipes-devtools/erlang/erlang/erlang-fix-build-issue-in-Yocto.patch25
-rw-r--r--meta-openstack/recipes-devtools/erlang/erlang_R15B.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/erlang/erlang/erlang-fix-build-issue-in-Yocto.patch b/meta-openstack/recipes-devtools/erlang/erlang/erlang-fix-build-issue-in-Yocto.patch
new file mode 100644
index 0000000..2d4b7b5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/erlang/erlang/erlang-fix-build-issue-in-Yocto.patch
@@ -0,0 +1,25 @@
1Upstream-Status: Inappropriate [The fix is specific to Yocto build env]
2
3Skip host library path check to fix following Yocto insane check issue:
4ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities.
5Rerun configure task after fixing this.
6
7Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
8
9--- otp_src_R15B/erts/configure.in.orig 2011-12-14 04:22:11.000000000 -0600
10+++ otp_src_R15B/erts/configure.in 2013-11-19 04:15:33.694334610 -0600
11@@ -1469,10 +1469,10 @@
12 # ln -s libdlpi.so.1 $try_dlpi_lib/libdlpi.so
13 ])
14 fi
15- LDFLAGS="-L$try_dlpi_lib -R$try_dlpi_lib $LDFLAGS"
16- unset -v try_dlpi_lib
17- AC_MSG_NOTICE([Extending the search to include /lib])
18- AC_CHECK_LIB(dlpi, dlpi_open)
19+# LDFLAGS="-L$try_dlpi_lib -R$try_dlpi_lib $LDFLAGS"
20+# unset -v try_dlpi_lib
21+# AC_MSG_NOTICE([Extending the search to include /lib])
22+# AC_CHECK_LIB(dlpi, dlpi_open)
23 if test x"$ac_cv_lib_dlpi_dlpi_open" = x"no"; then
24 LDFLAGS="$save_ldflags"
25 fi
diff --git a/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb b/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb
index 68d144b..d7fd310 100644
--- a/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb
+++ b/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb
@@ -55,5 +55,6 @@ FILES_${PN}-staticdev += "${libdir}/*/*/*/*.a ${libdir}/*/*/*/*/*.a ${libdir}/*/
55 55
56FILES_${PN}-libs-dbg += " ${libdir}/erlang/*/.debug ${libdir}/erlang/*/*/.debug ${libdir}/erlang/*/*/*/.debug ${libdir}/erlang/*/*/*/*/.debug ${libdir}/erlang/*/*/*/*/*/.debug " 56FILES_${PN}-libs-dbg += " ${libdir}/erlang/*/.debug ${libdir}/erlang/*/*/.debug ${libdir}/erlang/*/*/*/.debug ${libdir}/erlang/*/*/*/*/.debug ${libdir}/erlang/*/*/*/*/*/.debug "
57 57
58SRC_URI += "file://erlang-fix-build-issue-in-Yocto.patch"
58SRC_URI[md5sum] = "dd6c2a4807551b4a8a536067bde31d73" 59SRC_URI[md5sum] = "dd6c2a4807551b4a8a536067bde31d73"
59SRC_URI[sha256sum] = "5bc34fc34fc890f84bae7ff1f7c81fbec2c9aa28a0ef51a57d7a8192204d8aa2" 60SRC_URI[sha256sum] = "5bc34fc34fc890f84bae7ff1f7c81fbec2c9aa28a0ef51a57d7a8192204d8aa2"