summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/erlang/files
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-28 01:18:43 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-28 01:20:25 -0400
commit4bd68f289df9690c43c3484bdd464ed7411e051b (patch)
tree061e4c6b7985c716d75929022575ca3b461ecee9 /meta-openstack/recipes-devtools/erlang/files
parent689fe68f23a83a1d03d1ccdf383c0dd1028d83b8 (diff)
downloadmeta-cloud-services-4bd68f289df9690c43c3484bdd464ed7411e051b.tar.gz
erlang: update to R16B
Updating to the R16B erlang version from: https://github.com/joaohf/meta-erlang This is a cherry pick of the latest to avoid adding a new layer dependency. Eventually, this will be dropped and the layer used directly. We also update rabbitmq-server to depend on erlang-modules to get the proper support on target. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/erlang/files')
-rw-r--r--meta-openstack/recipes-devtools/erlang/files/erlang-fix-build-issue-in-Yocto.patch25
-rw-r--r--meta-openstack/recipes-devtools/erlang/files/fix-wx-configure.patch26
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/erlang/files/erlang-fix-build-issue-in-Yocto.patch b/meta-openstack/recipes-devtools/erlang/files/erlang-fix-build-issue-in-Yocto.patch
new file mode 100644
index 0000000..2d4b7b5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/erlang/files/erlang-fix-build-issue-in-Yocto.patch
@@ -0,0 +1,25 @@
1Upstream-Status: Inappropriate [The fix is specific to Yocto build env]
2
3Skip host library path check to fix following Yocto insane check issue:
4ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities.
5Rerun configure task after fixing this.
6
7Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
8
9--- otp_src_R15B/erts/configure.in.orig 2011-12-14 04:22:11.000000000 -0600
10+++ otp_src_R15B/erts/configure.in 2013-11-19 04:15:33.694334610 -0600
11@@ -1469,10 +1469,10 @@
12 # ln -s libdlpi.so.1 $try_dlpi_lib/libdlpi.so
13 ])
14 fi
15- LDFLAGS="-L$try_dlpi_lib -R$try_dlpi_lib $LDFLAGS"
16- unset -v try_dlpi_lib
17- AC_MSG_NOTICE([Extending the search to include /lib])
18- AC_CHECK_LIB(dlpi, dlpi_open)
19+# LDFLAGS="-L$try_dlpi_lib -R$try_dlpi_lib $LDFLAGS"
20+# unset -v try_dlpi_lib
21+# AC_MSG_NOTICE([Extending the search to include /lib])
22+# AC_CHECK_LIB(dlpi, dlpi_open)
23 if test x"$ac_cv_lib_dlpi_dlpi_open" = x"no"; then
24 LDFLAGS="$save_ldflags"
25 fi
diff --git a/meta-openstack/recipes-devtools/erlang/files/fix-wx-configure.patch b/meta-openstack/recipes-devtools/erlang/files/fix-wx-configure.patch
new file mode 100644
index 0000000..4a8c219
--- /dev/null
+++ b/meta-openstack/recipes-devtools/erlang/files/fix-wx-configure.patch
@@ -0,0 +1,26 @@
1Fix unsafe compilation path in the wx configure script.
2
3Index: wx/configure.in
4===================================================================
5--- otp_src_R15B.orig/lib/wx/configure.in
6+++ otp_src_R15B/lib/wx/configure.in
7@@ -234,18 +234,10 @@ if test X"$host_os" != X"win32" ; then
8 $as_unset ac_cv_header_GL_gl_h
9 AC_CHECK_HEADERS([GL/gl.h])
10 if test X"$ac_cv_header_GL_gl_h" != Xyes ; then
11- AC_MSG_NOTICE(Checking for OpenGL headers in /usr/local)
12- CPPFLAGS="-isystem /usr/local/include $saved_CPPFLAGS"
13- $as_unset ac_cv_header_GL_gl_h
14- AC_CHECK_HEADERS([GL/gl.h])
15- if test X"$ac_cv_header_GL_gl_h" != Xyes ; then
16 AC_MSG_WARN([No OpenGL headers found, wx will NOT be usable])
17 CPPFLAGS="$saved_CPPFLAGS"
18- else
19- GL_LIBS="-L/usr/local/lib $GL_LIBS"
20- fi
21 else
22- GL_LIBS="-L/usr/X11R6/lib $GL_LIBS"
23+ GL_LIBS="-L=/usr/X11R6/lib $GL_LIBS"
24 fi
25 fi
26 else