summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 15:25:10 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 15:25:10 -0400
commit71ef5b7acb5815c678cda0c115e98e6b1d06e1aa (patch)
tree85ede8002a48bc589301ab699b94504a0a88c3e4 /meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb
parent5d6cca1807a1b8c5fcef1f2cb2b0f466bb0eed5e (diff)
downloadmeta-cloud-services-71ef5b7acb5815c678cda0c115e98e6b1d06e1aa.tar.gz
openstack: add open-isci from git://github.com/DFE/HIPOS
To support the cinder iscsi backend, we need iscsi-* recipes. The HIPOS layer contains a reference implementation, but has distro bindings that we must avoid. So for now, we make a copy and reference the other layer. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb')
-rw-r--r--meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb
new file mode 100644
index 0000000..8d51460
--- /dev/null
+++ b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-kernel_2.0-873.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Open-iSCSI project is a high performance, transport independent, multi-platform implementation of RFC3720."
2HOMEPAGE = "http://www.open-iscsi.org/"
3LICENSE = "GPL"
4MACHINE_KERNEL_PR_append = "a"
5PR = "r2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
8
9SRC_URI = " http://www.open-iscsi.org/bits/open-iscsi-${PV}.tar.gz "
10
11
12S = "${WORKDIR}/open-iscsi-${PV}"
13TARGET_CC_ARCH += "${LDFLAGS}"
14
15inherit module
16
17do_compile () {
18 oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' LDFLAGS="" kernel
19}
20
21do_install() {
22 oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' LDFLAGS="" DESTDIR="${D}" install_kernel
23}
24
25
26SRC_URI[md5sum] = "8b8316d7c9469149a6cc6234478347f7"
27SRC_URI[sha256sum] = "7dd9f2f97da417560349a8da44ea4fcfe98bfd5ef284240a2cc4ff8e88ac7cd9"