summaryrefslogtreecommitdiffstats
path: root/meta-openstack-swift-deploy
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-04-10 15:30:11 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-11 14:15:28 -0400
commit3cd9620cfaecc614d3ab014351aa079b31c83a0e (patch)
tree9b3cdb4e7f40dc90dcb2ff5105bc124c40688ad5 /meta-openstack-swift-deploy
parent49f5cf2454fdd702edbc0cb1f7c767f273d3de31 (diff)
downloadmeta-cloud-services-3cd9620cfaecc614d3ab014351aa079b31c83a0e.tar.gz
add swift deploy layer
Create new layer meta-openstack-swift-deploy which when included into build will have Glance and Cinder Backup to use Swift as backend storage. This layer is also place for contain any Swift changes related to Swift deployment. Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack-swift-deploy')
-rw-r--r--meta-openstack-swift-deploy/README48
-rw-r--r--meta-openstack-swift-deploy/conf/layer.conf9
-rw-r--r--meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend2
-rw-r--r--meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend2
4 files changed, 61 insertions, 0 deletions
diff --git a/meta-openstack-swift-deploy/README b/meta-openstack-swift-deploy/README
new file mode 100644
index 0000000..9c8acb3
--- /dev/null
+++ b/meta-openstack-swift-deploy/README
@@ -0,0 +1,48 @@
1meta-openstack-swift-deploy
2=============================
3
4This layer provides support configuring and deploying the recipes to deploy
5OpenStack Swift.
6
7Dependencies
8------------
9
10This layer depends on:
11
12URI: git://github.com/openembedded/oe-core.git
13branch: master
14revision: HEAD
15prio: default
16
17URI: git://github.com/openembedded/meta-oe.git
18patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
19revision: HEAD
20layers: meta-oe
21 meta-networking
22 meta-ruby
23
24URI: git://git.yoctoproject.org/meta-virtualization
25branch: master
26revision: head
27
28meta-openstack
29branch: master
30revision: head
31
32Maintenance
33-----------
34
35Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
36
37When sending single patches, please using something like:
38'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
39
40Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
41
42License
43-------
44
45All metadata is MIT licensed unless otherwise stated. Source code included
46in tree for individual recipes is under the LICENSE stated in each recipe
47(.bb file) unless otherwise stated.
48
diff --git a/meta-openstack-swift-deploy/conf/layer.conf b/meta-openstack-swift-deploy/conf/layer.conf
new file mode 100644
index 0000000..3f8a20b
--- /dev/null
+++ b/meta-openstack-swift-deploy/conf/layer.conf
@@ -0,0 +1,9 @@
1# We have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend ${LAYERDIR}/classes/*.bbclass"
6
7BBFILE_COLLECTIONS += "openstack-swift-deploy-layer"
8BBFILE_PATTERN_openstack-swift-deploy-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_openstack-swift-deploy-layer = "6"
diff --git a/meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend b/meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend
new file mode 100644
index 0000000..74f1ec6
--- /dev/null
+++ b/meta-openstack-swift-deploy/recipes-devtools/python/python-cinder_git.bbappend
@@ -0,0 +1,2 @@
1# Force Cinder Backup to use Swift as backend store
2CINDER_BACKUP_BACKEND_DRIVER = "cinder.backup.drivers.swift"
diff --git a/meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend b/meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend
new file mode 100644
index 0000000..dd3e339
--- /dev/null
+++ b/meta-openstack-swift-deploy/recipes-devtools/python/python-glance_git.bbappend
@@ -0,0 +1,2 @@
1# Force Glance to use Swift as backend store
2GLANCE_DEFAULT_STORE = "swift"