summaryrefslogtreecommitdiffstats
path: root/meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-05-23 22:10:37 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-26 11:30:08 -0400
commitf91b219df2c17363058ebac5aa3907eb3c03a118 (patch)
treecf0dc3dbcd048e03869a99230f5e596f30f83ad2 /meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend
parent7ac076bc61edce7788442e4750d3b5b5545a29c1 (diff)
downloadmeta-cloud-services-f91b219df2c17363058ebac5aa3907eb3c03a118.tar.gz
nova controller test config
Tempest requires nova to be able to allocate floating ip from an default pool. So search for an existing floating ip pool and change default_floating_pool in nova.conf to this pool. Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend')
-rw-r--r--meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend b/meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend
new file mode 100644
index 0000000..c01d649
--- /dev/null
+++ b/meta-openstack-controller-test-config/recipes-devtools/python/python-nova_git.bbappend
@@ -0,0 +1,16 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://nova-test-config.init"
4
5do_install_append() {
6 install -m 0755 ${WORKDIR}/nova-test-config.init ${D}${sysconfdir}/init.d/nova-test-config
7}
8
9PACKAGES += " ${SRCNAME}-test-config"
10FILES_${SRCNAME}-test-config = "${sysconfdir}/init.d/nova-test-config"
11
12RDEPENDS_${SRCNAME}-tests += " ${SRCNAME}-test-config"
13
14INITSCRIPT_PACKAGES += " ${SRCNAME}-test-config"
15INITSCRIPT_NAME_${SRCNAME}-test-config = "nova-test-config"
16INITSCRIPT_PARAMS_${SRCNAME}-test-config = "defaults 95 10"