summaryrefslogtreecommitdiffstats
path: root/meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-05-23 22:10:37 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-26 11:30:08 -0400
commit7ac076bc61edce7788442e4750d3b5b5545a29c1 (patch)
tree0d452dbb71379cba1d3219bd1410884dc4c01fcf /meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend
parent0f728e306634535cbef82aad2024d5044d4fc032 (diff)
downloadmeta-cloud-services-7ac076bc61edce7788442e4750d3b5b5545a29c1.tar.gz
neutron controller test config
Tempest requires a shared network to exist prior to start the tempest test. Change neutron settings to first search for an existing a shared network, if there is none then prepare a simple real flat network that is based on openvswith. Signed-off-by: Vu Tran <vu.tran@windriver.com>
Diffstat (limited to 'meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend')
-rw-r--r--meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend b/meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend
new file mode 100644
index 0000000..2276456
--- /dev/null
+++ b/meta-openstack-controller-test-config/recipes-devtools/python/python-neutron_git.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://neutron-test-config.init"
4
5NEUTRON_CONF_EXT_ETH_IF ?= "eth0"
6
7do_install_append() {
8 sed -e "s:%NEUTRON_CONF_EXT_ETH_IF%:${NEUTRON_CONF_EXT_ETH_IF}:g" -i ${WORKDIR}/neutron-test-config.init
9 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${WORKDIR}/neutron-test-config.init
10 install -m 0755 ${WORKDIR}/neutron-test-config.init ${D}${sysconfdir}/init.d/neutron-test-config
11}
12
13PACKAGES += " ${SRCNAME}-test-config"
14FILES_${SRCNAME}-test-config = "${sysconfdir}/init.d/neutron-test-config"
15
16RDEPENDS_${SRCNAME}-tests += " ${SRCNAME}-test-config"
17
18INITSCRIPT_PACKAGES += " ${SRCNAME}-test-config"
19INITSCRIPT_NAME_${SRCNAME}-test-config = "neutron-test-config"
20INITSCRIPT_PARAMS_${SRCNAME}-test-config = "defaults 95 10"