summaryrefslogtreecommitdiffstats
path: root/meta-openstack-compute-deploy
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-23 16:34:28 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:15:42 -0400
commit581052b1783b4639705e5db520797ed81c1a0990 (patch)
tree9de1de059de42726ada811c8e96b8f6ee507e7c0 /meta-openstack-compute-deploy
parentf6a914b542f228488b66de6f6bd3dfb361e5a728 (diff)
downloadmeta-cloud-services-581052b1783b4639705e5db520797ed81c1a0990.tar.gz
meta-openstack-compute-deploy: initial creation
Add a nested layer that contains the configuration and appends necessary to deploy a compute node. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack-compute-deploy')
-rw-r--r--meta-openstack-compute-deploy/README48
-rw-r--r--meta-openstack-compute-deploy/classes/compute.bbclass2
-rw-r--r--meta-openstack-compute-deploy/conf/layer.conf9
-rw-r--r--meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend1
4 files changed, 60 insertions, 0 deletions
diff --git a/meta-openstack-compute-deploy/README b/meta-openstack-compute-deploy/README
new file mode 100644
index 0000000..12c2bae
--- /dev/null
+++ b/meta-openstack-compute-deploy/README
@@ -0,0 +1,48 @@
1meta-openstack-compute-deploy
2=============================
3
4This layer provides support configuring and deploying the recipes to create a
5compute node.
6
7Dependencies
8------------
9
10This layer depends on:
11
12URI: git://github.com/openembedded/oe-core.git
13branch: master
14revision: HEAD
15prio: default
16
17URI: git://github.com/openembedded/meta-oe.git
18patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
19revision: HEAD
20layers: meta-oe
21 meta-networking
22 meta-ruby
23
24URI: git://git.yoctoproject.org/meta-virtualization
25branch: master
26revision: head
27
28meta-openstack
29branch: master
30revision: head
31
32Maintenance
33-----------
34
35Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
36
37When sending single patches, please using something like:
38'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
39
40Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
41
42License
43-------
44
45All metadata is MIT licensed unless otherwise stated. Source code included
46in tree for individual recipes is under the LICENSE stated in each recipe
47(.bb file) unless otherwise stated.
48
diff --git a/meta-openstack-compute-deploy/classes/compute.bbclass b/meta-openstack-compute-deploy/classes/compute.bbclass
new file mode 100644
index 0000000..46749b1
--- /dev/null
+++ b/meta-openstack-compute-deploy/classes/compute.bbclass
@@ -0,0 +1,2 @@
1CONTROLLER_IP ?= "192.168.7.2"
2CONTROLLER_HOST ?= "192.168.7.2"
diff --git a/meta-openstack-compute-deploy/conf/layer.conf b/meta-openstack-compute-deploy/conf/layer.conf
new file mode 100644
index 0000000..44a035b
--- /dev/null
+++ b/meta-openstack-compute-deploy/conf/layer.conf
@@ -0,0 +1,9 @@
1# We have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
6
7BBFILE_COLLECTIONS += "openstack-compute-deploy-layer"
8BBFILE_PATTERN_openstack-compute-deploy-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_openstack-compute-deploy-layer = "6"
diff --git a/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend b/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
new file mode 100644
index 0000000..1c10253
--- /dev/null
+++ b/meta-openstack-compute-deploy/recipes-devtools/python/python-quantum_2013.1.3.bbappend
@@ -0,0 +1 @@
inherit compute