summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-22 10:28:10 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-27 22:44:47 -0400
commitfca3537b731b75d969cd32cf9bbecdfaec920958 (patch)
treebc35f1f7342ab4325dcdc7810a752215f73661bd
parent6efe4ead1bf61e8597cf13385a66ddd408ec1744 (diff)
downloadmeta-cloud-services-fca3537b731b75d969cd32cf9bbecdfaec920958.tar.gz
python3-memcached: upgrade 1.57 -> 1.59
Consolidate inc and bb files into a single bb file. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-memcached.inc21
-rw-r--r--meta-openstack/recipes-devtools/python/python3-memcached_git.bb24
2 files changed, 23 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-memcached.inc b/meta-openstack/recipes-devtools/python/python-memcached.inc
deleted file mode 100644
index 5acf43c..0000000
--- a/meta-openstack/recipes-devtools/python/python-memcached.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "Pure python memcached client"
2DESCRIPTION = "\
3 This software is a 100% Python interface to the memcached memory cache daemon. \
4 It is the client side software which allows storing values in one or more, possibly remote, \
5 memcached servers. Search google for memcached for more information."
6HOMEPAGE = "https://pypi.python.org/pypi/python-memcached/"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "file://PSF.LICENSE;md5=7dd786e8594f1e787da94a946557b40e"
10
11PV = "1.57+git${SRCPV}"
12SRCREV = "664bd3e23fe500fbde4c70636e2d24c8fd2f35af"
13
14SRC_URI = "git://github.com/linsomniac/python-memcached.git"
15
16S = "${WORKDIR}/git"
17
18RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-six \
20 "
21
diff --git a/meta-openstack/recipes-devtools/python/python3-memcached_git.bb b/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
index de96734..a129725 100644
--- a/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
@@ -1,2 +1,24 @@
1require python-memcached.inc 1SUMMARY = "Pure python memcached client"
2DESCRIPTION = "\
3 This software is a 100% Python interface to the memcached memory cache daemon. \
4 It is the client side software which allows storing values in one or more, possibly remote, \
5 memcached servers. Search google for memcached for more information."
6HOMEPAGE = "https://pypi.python.org/pypi/python-memcached/"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "file://PSF.LICENSE;md5=7dd786e8594f1e787da94a946557b40e"
10
11PV = "1.59+git${SRCPV}"
12SRCREV = "959e068fec8b4c956b0d82269336818e667726e7"
13
14SRC_URI = "git://github.com/linsomniac/python-memcached.git"
15
16S = "${WORKDIR}/git"
17
2inherit setuptools3 18inherit setuptools3
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-six \
22 ${PYTHON_PN}-pickle \
23 "
24