summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-09 11:03:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-09 12:07:08 -0400
commitf836d97e0e2024e4f1c8a22f6c92f3309fbf6fc8 (patch)
tree0391ce454ab20a3ee74aa41733712282d7f565cc
parent6d229bc5925fbe3c0e3ecb16baf3be57782a7f47 (diff)
downloadmeta-cloud-services-f836d97e0e2024e4f1c8a22f6c92f3309fbf6fc8.tar.gz
tox: introduce the tox framework and dependencies
To enabled OpenStack unit testing: https://wiki.openstack.org/wiki/Testing#Unit_Testing_with_Tox We introduce tox and its depedencies. Adding it to the tempest RDEPENDS ensures that it is installed along with the rest of the test frameworks. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-py_1.4.20.bb25
-rw-r--r--meta-openstack/recipes-devtools/python/python-pytest_2.5.2.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python-tox_1.7.1.bb39
-rw-r--r--meta-openstack/recipes-devtools/python/python-virtualenv_1.11.4.bb25
4 files changed, 113 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-py_1.4.20.bb b/meta-openstack/recipes-devtools/python/python-py_1.4.20.bb
new file mode 100644
index 0000000..0040cd7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-py_1.4.20.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "library with cross-python path, ini-parsing, io, code, log facilities"
2HOMEPAGE = " http://pylib.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a6bb0320b04a0a503f12f69fea479de9"
6
7PR = "r0"
8
9SRCNAME = "py"
10SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "5f1708be5482f3ff6711dfd6cafd45e0"
13SRC_URI[sha256sum] = "23c99d99ebb2a60eb7023b7577bfc988acb0092082257a57189f100ce84b72f1"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 "
22
23RDEPENDS_${PN} += " \
24 python-virtualenv \
25 "
diff --git a/meta-openstack/recipes-devtools/python/python-pytest_2.5.2.bb b/meta-openstack/recipes-devtools/python/python-pytest_2.5.2.bb
new file mode 100644
index 0000000..5ea4a10
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pytest_2.5.2.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "pytest: simple powerful testing with Python"
2HOMEPAGE = " http://pytest.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a6bb0320b04a0a503f12f69fea479de9"
6
7PR = "r0"
8
9SRCNAME = "pytest"
10SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "8ea3d1939e81514ccba9ba0e9566b5be"
13SRC_URI[sha256sum] = "962452611799878616d6df5e7674cc2c356f902ed005dc4dae9d4e79bb8abda4"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 "
22
23RDEPENDS_${PN} += " \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python-tox_1.7.1.bb b/meta-openstack/recipes-devtools/python/python-tox_1.7.1.bb
new file mode 100644
index 0000000..7010fa7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-tox_1.7.1.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "virtualenv-based automation of test activities"
2HOMEPAGE = "http://tox.testrun.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2d0fc2c2c954dc4d41043e67d4a8d8e7"
6
7PR = "r0"
8
9SRCNAME = "tox"
10SRC_URI = "http://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "ec85bbfc7bd29600e91aa0e9754645d0"
13SRC_URI[sha256sum] = "869cb9e07847a9f0238f5a5029f3621504a5a3ec05af6d878e879b354c6851c4"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 "
22
23RDEPENDS_${PN} += " \
24 python-virtualenv \
25 python-py \
26 python-pytest \
27 "
28
29do_install_append() {
30
31 install -d ${D}/${sysconfdir}/${SRCNAME}
32 cp ${S}/tox.ini ${D}/${sysconfdir}/${SRCNAME}
33 cp ${S}/setup.py ${D}/${sysconfdir}/${SRCNAME}
34 cp ${S}/README.rst ${D}/${sysconfdir}/${SRCNAME}
35
36 ln -s ${PYTHON_SITEPACKAGES_DIR}/tox ${D}/${sysconfdir}/${SRCNAME}/tox
37}
38
39FILES_${PN} += "${sysconfdir}/${SRCNAME}/*"
diff --git a/meta-openstack/recipes-devtools/python/python-virtualenv_1.11.4.bb b/meta-openstack/recipes-devtools/python/python-virtualenv_1.11.4.bb
new file mode 100644
index 0000000..c2fb657
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-virtualenv_1.11.4.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Virtual Python Environment builder"
2HOMEPAGE = "https://pypi.python.org/pypi/virtualenv"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=53df9f8889d6a5fba83f425abe3b1568"
6
7PR = "r0"
8
9SRCNAME = "virtualenv"
10SRC_URI = "http://pypi.python.org/packages/source/v/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "9accc2d3f0ec1da479ce2c3d1fdff06e"
13SRC_URI[sha256sum] = "cf3d958f28eb7470bd04262ef397580a2e57407f2ee2c88e9b2892218eb0465a"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 "
22
23RDEPENDS_${PN} += " \
24 python-dateutil \
25 "