summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-11-29 10:18:52 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-01 23:17:09 -0500
commitec16a992e6589fc5ddcd80510120f0d960794f65 (patch)
treeab78bff35a762dec945d42fd0cf90717ef28ae43
parentc5b5ae21fec08988a9c4aa0a2a7be239f7a116dc (diff)
downloadmeta-cloud-services-ec16a992e6589fc5ddcd80510120f0d960794f65.tar.gz
python-cachetools: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cachetools.inc14
-rw-r--r--meta-openstack/recipes-devtools/python/python-cachetools_git.bb16
-rw-r--r--meta-openstack/recipes-devtools/python/python3-cachetools_git.bb2
3 files changed, 17 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cachetools.inc b/meta-openstack/recipes-devtools/python/python-cachetools.inc
new file mode 100644
index 0000000..a67794f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cachetools.inc
@@ -0,0 +1,14 @@
1DESCRIPTION = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=96c958336b659af4dad628356c5e43b6"
6
7SRCNAME = "cachetools"
8
9PV = "1.1.5+git${SRCPV}"
10SRCREV = "42853733d0caf68ef5bf5933a377572b05437e2c"
11
12SRC_URI = "git://github.com/tkem/${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
diff --git a/meta-openstack/recipes-devtools/python/python-cachetools_git.bb b/meta-openstack/recipes-devtools/python/python-cachetools_git.bb
index f3d89b3..ff0049f 100644
--- a/meta-openstack/recipes-devtools/python/python-cachetools_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cachetools_git.bb
@@ -1,16 +1,2 @@
1DESCRIPTION = "Extensible memoizing collections and decorators" 1require python-cachetools.inc
2HOMEPAGE = "https://github.com/tkem/cachetools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=96c958336b659af4dad628356c5e43b6"
6
7SRCNAME = "cachetools"
8
9PV = "1.1.5+git${SRCPV}"
10SRCREV = "42853733d0caf68ef5bf5933a377572b05437e2c"
11
12SRC_URI = "git://github.com/tkem/${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools 2inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python3-cachetools_git.bb b/meta-openstack/recipes-devtools/python/python3-cachetools_git.bb
new file mode 100644
index 0000000..14e8b8c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-cachetools_git.bb
@@ -0,0 +1,2 @@
1require python-cachetools.inc
2inherit setuptools3