summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Hartman <hnathan918@gmail.com>2020-02-20 11:58:04 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-27 17:15:47 -0500
commiteb71de34422991c564731fe1214f76280ca5469f (patch)
tree93c5907840cbf4c5dd914c3d271bd4309a95d722
parentafeb0402c69eb9db7ba323e11911f4c98c9288ee (diff)
downloadmeta-cloud-services-eb71de34422991c564731fe1214f76280ca5469f.tar.gz
Initial sigdump and serverengine ruby recipes
Signed-off-by: Nathan Hartman <hnathan918@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb13
-rw-r--r--meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb11
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
new file mode 100644
index 0000000..1ed8f9e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
@@ -0,0 +1,13 @@
1SUMMARY = 'A framework to implement robust multiprocess servers like Unicorn'
2HOMEPAGE = 'https://rubygems.org/gems/serverengine'
3
4LICENSE = 'Apache-2.0'
5LIC_FILES_CHKSUM = 'file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57'
6
7SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;tag=v2.2.1'
8
9S = '${WORKDIR}/git'
10
11RDEPENDS_${PN} = "sigdump"
12
13inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb b/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
new file mode 100644
index 0000000..fbf651e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
@@ -0,0 +1,11 @@
1SUMMARY = "Use signal to show stacktrace of a Ruby process without restarting it"
2HOMEPAGE = "https://github.com/frsyuki/sigdump"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07d6218b18fb6826f04fd32b4918f085"
6
7SRC_URI = "git://github.com/frsyuki/sigdump.git;protocol=https;tag=v0.2.4"
8
9S = "${WORKDIR}/git"
10
11inherit ruby