summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-29 11:20:22 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-01 23:11:59 -0400
commitde973cfa97c333c39a3260b12e9f693da64a9cc5 (patch)
treefc039ca5a63dbe03bf024a47c92eef15d354ef47
parent80db6a5dbed8a6daf3c2785dfdb7af072eeab085 (diff)
downloadmeta-cloud-services-de973cfa97c333c39a3260b12e9f693da64a9cc5.tar.gz
python3-pathlib: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pathlib.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb25
2 files changed, 23 insertions, 25 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pathlib.inc b/meta-openstack/recipes-devtools/python/python-pathlib.inc
deleted file mode 100644
index 1df01f3..0000000
--- a/meta-openstack/recipes-devtools/python/python-pathlib.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Object-oriented filesystem paths"
2DESCRIPTION = "pathlib offers a set of classes to handle filesystem paths. \
3It offers the following advantages over using string objects: \
4- No more cumbersome use of os and os.path functions. \
5- Embodies the semantics of different path types. \
6- Well-defined semantics, eliminating any warts or ambiguities. \
7"
8HOMEPAGE = "https://pypi.python.org/pypi/pathlib"
9SECTION = "devel/python"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b6557c860f0fc867aeab30afd649753"
12
13SRC_URI[md5sum] = "5099ed48be9b1ee29b31c82819240537"
14SRC_URI[sha256sum] = "6940718dfc3eff4258203ad5021090933e5c04707d5ca8cc9e73c94a7894ea9f"
15
16inherit pypi
17
18DEPENDS += " \
19 ${PYTHON_PN}-pip \
20"
21
22RDEPENDS_${PN} += " \
23"
diff --git a/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb b/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
index afed21e..059b4ff 100644
--- a/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
+++ b/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
@@ -1,2 +1,23 @@
1require python-pathlib.inc 1SUMMARY = "Object-oriented filesystem paths"
2inherit setuptools3 2DESCRIPTION = "pathlib offers a set of classes to handle filesystem paths. \
3It offers the following advantages over using string objects: \
4- No more cumbersome use of os and os.path functions. \
5- Embodies the semantics of different path types. \
6- Well-defined semantics, eliminating any warts or ambiguities. \
7"
8HOMEPAGE = "https://pypi.python.org/pypi/pathlib"
9SECTION = "devel/python"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b6557c860f0fc867aeab30afd649753"
12
13SRC_URI[md5sum] = "5099ed48be9b1ee29b31c82819240537"
14SRC_URI[sha256sum] = "6940718dfc3eff4258203ad5021090933e5c04707d5ca8cc9e73c94a7894ea9f"
15
16inherit setuptools3 pypi
17
18DEPENDS += " \
19 ${PYTHON_PN}-pip \
20"
21
22RDEPENDS_${PN} += " \
23"