summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-12-15 15:09:38 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-21 17:15:21 -0500
commitde757baf471d6dc74b14ff9224e5ae47add897e1 (patch)
treec016cc725913c636e784764458efd858898723b6
parentd0e08e479e83f7beb6e3172b7e1f0d0750cc72e4 (diff)
downloadmeta-cloud-services-de757baf471d6dc74b14ff9224e5ae47add897e1.tar.gz
python-futures: Remove recipe
| This backport is meant only for Python 2. | It does not work on Python 3, and Python 3 users do not need it as the concurrent.futures package is available in the standard library. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-futures_git.bb25
1 files changed, 0 insertions, 25 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-futures_git.bb b/meta-openstack/recipes-devtools/python/python-futures_git.bb
deleted file mode 100644
index 493aef1..0000000
--- a/meta-openstack/recipes-devtools/python/python-futures_git.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "Backport of the concurrent.futures package from Python 3.2"
2HOMEPAGE = "https://github.com/agronholm/pythonfutures"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dd6708d05936d3f6c4e20ed14c87b5e3"
6
7PV = "3.3.0+git${SRCPV}"
8SRCREV = "ec78e222ece60721fc92a6c650df3116cb15d24e"
9
10SRCNAME = "futures"
11SRC_URI = "git://github.com/agronholm/python${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 python-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "