summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-09-16 10:45:44 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-18 13:57:12 -0400
commitd60764e54a6c969e9c125b9cdbea6b6454d00792 (patch)
tree958f8918589e0423f03ac4f47d1df9755a9e72f6
parent5c1e3a3941dc39cecc701562e18f1745848a5617 (diff)
downloadmeta-cloud-services-d60764e54a6c969e9c125b9cdbea6b6454d00792.tar.gz
python-osc-lib: Python3 version fix
Specifies the major Python version being built using PYTHON_PN. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-osc-lib.inc27
-rw-r--r--meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb8
3 files changed, 19 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-osc-lib.inc b/meta-openstack/recipes-devtools/python/python-osc-lib.inc
index 58e994c..0589137 100644
--- a/meta-openstack/recipes-devtools/python/python-osc-lib.inc
+++ b/meta-openstack/recipes-devtools/python/python-osc-lib.inc
@@ -7,17 +7,24 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7SRC_URI[md5sum] = "5e91028524b50a72f9913ccd2994cf77" 7SRC_URI[md5sum] = "5e91028524b50a72f9913ccd2994cf77"
8SRC_URI[sha256sum] = "9dcd3b55bd887525a7020a8adbabb661a340fc4a4a707950dc1c6f0b286cce77" 8SRC_URI[sha256sum] = "9dcd3b55bd887525a7020a8adbabb661a340fc4a4a707950dc1c6f0b286cce77"
9 9
10inherit pypi
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 ${PYTHON_PN}-pbr-native \
15 "
16
10RDEPENDS_${PN} += " \ 17RDEPENDS_${PN} += " \
11 python-pbr \ 18 ${PYTHON_PN}-pbr \
12 python-six \ 19 ${PYTHON_PN}-six \
13 python-babel \ 20 ${PYTHON_PN}-babel \
14 python-cliff \ 21 ${PYTHON_PN}-cliff \
15 python-keystoneauth1 \ 22 ${PYTHON_PN}-keystoneauth1 \
16 python-os-client-config \ 23 ${PYTHON_PN}-os-client-config \
17 python-oslo.i18n \ 24 ${PYTHON_PN}-oslo.i18n \
18 python-oslo.utils \ 25 ${PYTHON_PN}-oslo.utils \
19 python-simplejson \ 26 ${PYTHON_PN}-simplejson \
20 python-stevedore \ 27 ${PYTHON_PN}-stevedore \
21 " 28 "
22 29
23CLEANBROKEN = "1" 30CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb b/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb
index 4ea2de2..d8c72e7 100644
--- a/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-osc-lib_1.13.0.bb
@@ -1,7 +1,2 @@
1inherit setuptools pypi 1inherit setuptools
2require python-osc-lib.inc 2require python-osc-lib.inc
3
4# Satisfy setup.py 'setup_requires'
5DEPENDS += " \
6 python-pbr-native \
7 "
diff --git a/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb b/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb
index 63265d9..256c286 100644
--- a/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-osc-lib_1.13.0.bb
@@ -1,8 +1,2 @@
1inherit setuptools3 pypi 1inherit setuptools3
2require python-osc-lib.inc 2require python-osc-lib.inc
3
4# Satisfy setup.py 'setup_requires'
5DEPENDS += " \
6 python3-pbr-native \
7 "
8