summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFagundes, Paulo <paulohefagundes@gmail.com>2020-07-09 09:24:51 -0600
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-14 16:24:25 -0400
commitd4ddf6c7f1484f453b5ecab1a5ef6d313cf6d86a (patch)
tree2de443c3ae0f4200d6703983ef567ab385278b00
parent1aa80ad25a8359d42f15be4f469e1b145fdbf006 (diff)
downloadmeta-cloud-services-d4ddf6c7f1484f453b5ecab1a5ef6d313cf6d86a.tar.gz
salt: bump 3000 -> 3001
Signed-off-by: Paulo Fagundes <paulohefagundes@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-support/salt/salt/set_python_location_hashbang.patch158
-rw-r--r--meta-openstack/recipes-support/salt/salt_3001.bb (renamed from meta-openstack/recipes-support/salt/salt_3000.bb)7
2 files changed, 3 insertions, 162 deletions
diff --git a/meta-openstack/recipes-support/salt/salt/set_python_location_hashbang.patch b/meta-openstack/recipes-support/salt/salt/set_python_location_hashbang.patch
deleted file mode 100644
index 76d6f41..0000000
--- a/meta-openstack/recipes-support/salt/salt/set_python_location_hashbang.patch
+++ /dev/null
@@ -1,158 +0,0 @@
1Upstream-Status: Pending
2
3# The Salt SysV scripts require that the process name of the salt
4# components have the form "salt-<component>".
5# The current python shebangs on the salt components scripts spwans
6# processes that are generically named python. Changed shebang so
7# process names will be identifiable by the init scripts.
8
9diff --git a/scripts/salt b/scripts/salt
10index 1a6d6b4d0c..0408ad07b2 100755
11--- a/scripts/salt
12+++ b/scripts/salt
13@@ -1,4 +1,4 @@
14-#!/usr/bin/env python
15+#!/usr/bin/env python3
16 '''
17 Publish commands to the salt system from the command line on the master.
18 '''
19diff --git a/scripts/salt-api b/scripts/salt-api
20index 6f028bacb6..7a51117822 100755
21--- a/scripts/salt-api
22+++ b/scripts/salt-api
23@@ -1,4 +1,4 @@
24-#!/usr/bin/env python
25+#!/usr/bin/env python3
26
27 # Import salt libs
28 from salt.scripts import salt_api
29diff --git a/scripts/salt-call b/scripts/salt-call
30index 5b8a8f3935..9ddda9428d 100755
31--- a/scripts/salt-call
32+++ b/scripts/salt-call
33@@ -1,4 +1,4 @@
34-#!/usr/bin/env python
35+#!/usr/bin/env python3
36 '''
37 Directly call a salt command in the modules, does not require a running salt
38 minion to run.
39diff --git a/scripts/salt-cloud b/scripts/salt-cloud
40index e977b68179..01c593881c 100755
41--- a/scripts/salt-cloud
42+++ b/scripts/salt-cloud
43@@ -1,4 +1,4 @@
44-#!/usr/bin/env python
45+#!/usr/bin/env python3
46 '''
47 Publish commands to the salt system from the command line on the master.
48 '''
49diff --git a/scripts/salt-cp b/scripts/salt-cp
50index 3da660d137..dcc3f11554 100755
51--- a/scripts/salt-cp
52+++ b/scripts/salt-cp
53@@ -1,4 +1,4 @@
54-#!/usr/bin/env python
55+#!/usr/bin/env python3
56 '''
57 Publish commands to the salt system from the command line on the master.
58 '''
59diff --git a/scripts/salt-extend b/scripts/salt-extend
60index 5385a7b6a9..b01c584bb4 100755
61--- a/scripts/salt-extend
62+++ b/scripts/salt-extend
63@@ -1,4 +1,4 @@
64-#!/usr/bin/env python
65+#!/usr/bin/env python3
66 '''
67 Quickstart for creating an/or extending the functionality of your SaltStack installation
68
69diff --git a/scripts/salt-key b/scripts/salt-key
70index cb26dfd5a6..596b202a3f 100755
71--- a/scripts/salt-key
72+++ b/scripts/salt-key
73@@ -1,4 +1,4 @@
74-#!/usr/bin/env python
75+#!/usr/bin/env python3
76 '''
77 Manage the authentication keys with salt-key
78 '''
79diff --git a/scripts/salt-master b/scripts/salt-master
80index b4323bd532..52bb47dc47 100755
81--- a/scripts/salt-master
82+++ b/scripts/salt-master
83@@ -1,4 +1,4 @@
84-#!/usr/bin/env python
85+#!/usr/bin/env python3
86 '''
87 Start the salt-master
88 '''
89diff --git a/scripts/salt-minion b/scripts/salt-minion
90index 74a9fa1d67..4a23ed9122 100755
91--- a/scripts/salt-minion
92+++ b/scripts/salt-minion
93@@ -1,4 +1,4 @@
94-#!/usr/bin/env python
95+#!/usr/bin/env python3
96 '''
97 This script is used to kick off a salt minion daemon
98 '''
99diff --git a/scripts/salt-proxy b/scripts/salt-proxy
100index e921e6590b..443774ef85 100755
101--- a/scripts/salt-proxy
102+++ b/scripts/salt-proxy
103@@ -1,4 +1,4 @@
104-#!/usr/bin/env python
105+#!/usr/bin/env python3
106 # -*- coding: utf-8 -*-
107 '''
108 This script is used to kick off a salt proxy minion daemon
109diff --git a/scripts/salt-run b/scripts/salt-run
110index 2b2d86554c..cfef160ab0 100755
111--- a/scripts/salt-run
112+++ b/scripts/salt-run
113@@ -1,4 +1,4 @@
114-#!/usr/bin/env python
115+#!/usr/bin/env python3
116 '''
117 Execute a salt convenience routine
118 '''
119diff --git a/scripts/salt-ssh b/scripts/salt-ssh
120index 4f21baa5f4..77bb6ceb38 100755
121--- a/scripts/salt-ssh
122+++ b/scripts/salt-ssh
123@@ -1,4 +1,4 @@
124-#!/usr/bin/env python
125+#!/usr/bin/env python3
126 '''
127 Execute the salt ssh system
128 '''
129diff --git a/scripts/salt-syndic b/scripts/salt-syndic
130index d6faf2df63..896bf5f3b0 100755
131--- a/scripts/salt-syndic
132+++ b/scripts/salt-syndic
133@@ -1,4 +1,4 @@
134-#!/usr/bin/env python
135+#!/usr/bin/env python3
136 '''
137 This script is used to kick off a salt syndic daemon
138 '''
139diff --git a/scripts/salt-unity b/scripts/salt-unity
140index b0a2d31597..ff1fa9034c 100755
141--- a/scripts/salt-unity
142+++ b/scripts/salt-unity
143@@ -1,4 +1,4 @@
144-#!/usr/bin/env python
145+#!/usr/bin/env python3
146
147 from salt.scripts import salt_unity
148
149diff --git a/scripts/spm b/scripts/spm
150index 027864ee11..4d9b648b5d 100755
151--- a/scripts/spm
152+++ b/scripts/spm
153@@ -1,4 +1,4 @@
154-#!/usr/bin/env python
155+#!/usr/bin/env python3
156 '''
157 Publish commands to the salt system from the command line on the master.
158
diff --git a/meta-openstack/recipes-support/salt/salt_3000.bb b/meta-openstack/recipes-support/salt/salt_3001.bb
index c2bc8da..5140470 100644
--- a/meta-openstack/recipes-support/salt/salt_3000.bb
+++ b/meta-openstack/recipes-support/salt/salt_3001.bb
@@ -19,11 +19,10 @@ PACKAGECONFIG[zeromq] = ",,python3-pyzmq python3-pycrypto,"
19PACKAGECONFIG[tcp] = ",,python3-pycrypto" 19PACKAGECONFIG[tcp] = ",,python3-pycrypto"
20 20
21SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \ 21SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \
22 file://set_python_location_hashbang.patch \
23" 22"
24 23
25SRC_URI[md5sum] = "8084ef6f2a275b627ae364b9d562b4ff" 24SRC_URI[md5sum] = "ae06cef7557e237a954491a069e79a25"
26SRC_URI[sha256sum] = "04fbc64933b375cbbefc9576bcc65167b74d5eec7f58e64d096d67529ea66500" 25SRC_URI[sha256sum] = "5ca60d1b2cc8e63db50995bd8b117914eeaf57c48ce2b3a3731ee57163adf154"
27 26
28 27
29SYSTEMD_AUTO_ENABLE_${PN}-master = "disable" 28SYSTEMD_AUTO_ENABLE_${PN}-master = "disable"
@@ -100,7 +99,7 @@ SUMMARY_${PN}-common = "shared libraries that salt requires for all packages"
100DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \ 99DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \
101salt-master, salt-minion, and salt-syndic require to function." 100salt-master, salt-minion, and salt-syndic require to function."
102RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0)" 101RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0)"
103RRECOMMENDS_${PN}-common = "lsb" 102RRECOMMENDS_${PN}-common = "lsb-release"
104RSUGGESTS_${PN}-common = "python3-mako python3-git" 103RSUGGESTS_${PN}-common = "python3-mako python3-git"
105RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)" 104RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)"
106CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}" 105CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}"