summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-07-28 09:35:06 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-30 15:48:00 -0400
commitcf059689f866db9c35dc3c5322562a562cb96450 (patch)
tree37eacf675ecc8e772a167ea150cd2cb4f42d2789
parentd9123a0f2f8de17b7d5776c1e4e5b49246ae6291 (diff)
downloadmeta-cloud-services-cf059689f866db9c35dc3c5322562a562cb96450.tar.gz
python3-semantic-version: upgrade 2.4.2 -> 2.8.5
-License-Update: Copyright update. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>/ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-semantic-version.inc24
-rw-r--r--meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb13
4 files changed, 13 insertions, 28 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-semantic-version.inc b/meta-openstack/recipes-devtools/python/python-semantic-version.inc
deleted file mode 100644
index e003c0c..0000000
--- a/meta-openstack/recipes-devtools/python/python-semantic-version.inc
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "A library which provides a few tools to handle SemVer in Python."
2HOMEPAGE = "http://pypi.python.org/pypi/semantic_version"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a7dcaa0740d59f8f13ef05a3d0ed7313"
6
7PYPI_PACKAGE = "semantic_version"
8
9SRC_URI[md5sum] = "fd7d5ade76e78d8540b9a4044496a57c"
10SRC_URI[sha256sum] = "7e8b7fa74a3bc9b6e90b15b83b9bc2377c78eaeae3447516425f475d5d6932d2"
11
12#export BUILD_SYS
13#export HOST_SYS
14
15inherit pypi
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb b/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
deleted file mode 100644
index f4191f5..0000000
--- a/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-semantic-version.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb b/meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb
deleted file mode 100644
index f4191f5..0000000
--- a/meta-openstack/recipes-devtools/python/python3-semantic-version_2.4.2.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-semantic-version.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb b/meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb
new file mode 100644
index 0000000..b91b655
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb
@@ -0,0 +1,13 @@
1DESCRIPTION = "A library which provides a few tools to handle SemVer in Python."
2HOMEPAGE = "http://pypi.python.org/pypi/semantic_version"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2"
6
7PYPI_PACKAGE = "semantic_version"
8
9SRC_URI[md5sum] = "76d7364def7ee487b6153d40b13de904"
10SRC_URI[sha256sum] = "d2cb2de0558762934679b9a104e82eca7af448c9f4974d1f3eeccff651df8a54"
11
12inherit setuptools3 pypi
13