summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-03 20:45:01 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-09-06 18:00:08 -0400
commitcdee0a74c98e7c39eabfa9b633f33c4d1db98e17 (patch)
tree7fdadeaf4ca739ab0c040fefecbf1c9ef0f99eaa
parentb1bd021f0b52910b5e560580d8536bf07cdc386d (diff)
downloadmeta-cloud-services-cdee0a74c98e7c39eabfa9b633f33c4d1db98e17.tar.gz
erlang: fix QA error and use ${libdir}
The lib/wx subcomponent of erlang generates the following QA error: ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities. Stop configure looking for files on the host, specifically unsafe paths such as /usr/local/include. Additionally we should be using ${libdir} and not "lib", since 64 bit builds will use lib64 and by using ${libdir} we adapt automatically. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/erlang/erlang.inc2
-rw-r--r--meta-openstack/recipes-devtools/erlang/erlang/fix-wx-configure.patch26
-rw-r--r--meta-openstack/recipes-devtools/erlang/erlang_R15B.bb6
3 files changed, 32 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/erlang/erlang.inc b/meta-openstack/recipes-devtools/erlang/erlang.inc
index e4aad1c..32ee135 100644
--- a/meta-openstack/recipes-devtools/erlang/erlang.inc
+++ b/meta-openstack/recipes-devtools/erlang/erlang.inc
@@ -9,6 +9,8 @@ LIC_FILES_CHKSUM = "file://EPLICENCE;md5=09f9063ea35bc5bd124df2fda1d9d2c7"
9UPSTREAM_VERSION = "${@bb.data.getVar('PV', d, 1).replace('.', '-')}" 9UPSTREAM_VERSION = "${@bb.data.getVar('PV', d, 1).replace('.', '-')}"
10 10
11SRC_URI = "http://erlang.org/download/otp_src_${UPSTREAM_VERSION}.tar.gz" 11SRC_URI = "http://erlang.org/download/otp_src_${UPSTREAM_VERSION}.tar.gz"
12SRC_URI += "file://fix-wx-configure.patch"
13
12S = "${WORKDIR}/otp_src_${UPSTREAM_VERSION}" 14S = "${WORKDIR}/otp_src_${UPSTREAM_VERSION}"
13 15
14PARALLEL_MAKE = "" 16PARALLEL_MAKE = ""
diff --git a/meta-openstack/recipes-devtools/erlang/erlang/fix-wx-configure.patch b/meta-openstack/recipes-devtools/erlang/erlang/fix-wx-configure.patch
new file mode 100644
index 0000000..4a8c219
--- /dev/null
+++ b/meta-openstack/recipes-devtools/erlang/erlang/fix-wx-configure.patch
@@ -0,0 +1,26 @@
1Fix unsafe compilation path in the wx configure script.
2
3Index: wx/configure.in
4===================================================================
5--- otp_src_R15B.orig/lib/wx/configure.in
6+++ otp_src_R15B/lib/wx/configure.in
7@@ -234,18 +234,10 @@ if test X"$host_os" != X"win32" ; then
8 $as_unset ac_cv_header_GL_gl_h
9 AC_CHECK_HEADERS([GL/gl.h])
10 if test X"$ac_cv_header_GL_gl_h" != Xyes ; then
11- AC_MSG_NOTICE(Checking for OpenGL headers in /usr/local)
12- CPPFLAGS="-isystem /usr/local/include $saved_CPPFLAGS"
13- $as_unset ac_cv_header_GL_gl_h
14- AC_CHECK_HEADERS([GL/gl.h])
15- if test X"$ac_cv_header_GL_gl_h" != Xyes ; then
16 AC_MSG_WARN([No OpenGL headers found, wx will NOT be usable])
17 CPPFLAGS="$saved_CPPFLAGS"
18- else
19- GL_LIBS="-L/usr/local/lib $GL_LIBS"
20- fi
21 else
22- GL_LIBS="-L/usr/X11R6/lib $GL_LIBS"
23+ GL_LIBS="-L=/usr/X11R6/lib $GL_LIBS"
24 fi
25 fi
26 else
diff --git a/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb b/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb
index bb9448a..8f5d509 100644
--- a/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb
+++ b/meta-openstack/recipes-devtools/erlang/erlang_R15B.bb
@@ -20,6 +20,7 @@ NATIVE_BIN = "${TMPDIR}/work/erlang-native-${PV}-${PR}/otp_src_${UPSTREAM_VERSIO
20do_configure() { 20do_configure() {
21 21
22 cd ${S}/erts; autoreconf; cd - 22 cd ${S}/erts; autoreconf; cd -
23 cd ${S}/lib/wx; autoreconf; cd -
23 24
24 . ${CONFIG_SITE} 25 . ${CONFIG_SITE}
25 26
@@ -41,9 +42,10 @@ do_install() {
41 TARGET=${TARGET_SYS} \ 42 TARGET=${TARGET_SYS} \
42 PATH=${NATIVE_BIN}:$PATH \ 43 PATH=${NATIVE_BIN}:$PATH \
43 oe_runmake 'INSTALL_PREFIX=${D}' install 44 oe_runmake 'INSTALL_PREFIX=${D}' install
45
44 for f in erl start 46 for f in erl start
45 do sed -i -e 's:ROOTDIR=.*:ROOTDIR=/usr/lib/erlang:' \ 47 do sed -i -e 's:ROOTDIR=.*:ROOTDIR=/${libdir}/erlang:' \
46 ${D}/usr/lib/erlang/erts-*/bin/$f ${D}/usr/lib/erlang/bin/$f 48 ${D}/${libdir}/erlang/erts-*/bin/$f ${D}/${libdir}/erlang/bin/$f
47 done 49 done
48} 50}
49 51