summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2023-05-25 14:12:00 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-09-08 20:07:34 +0000
commitcd048e11c4600636714051c787264a52be19c3f8 (patch)
tree83ae818e2033f499e24bdf911b1b6f5767bf369c
parente1be40b7a57547068d254110dad092ff153fe67b (diff)
downloadmeta-cloud-services-cd048e11c4600636714051c787264a52be19c3f8.tar.gz
python3-ansible: Add locale-base-en-us to RDEPENDS
Fixes: # export LANG='en_US.UTF-8' # ansible --version ERROR: Ansible requires the locale encoding to be UTF-8; Detected None. # python3 Python 3.10.9 (main, Dec 6 2022, 18:44:57) [GCC 11.3.0] on linux Type "help", "copyright", "credits" or "license" for more information. >>> import locale >>> locale.setlocale(locale.LC_CTYPE, ("en_US", "UTF-8")) Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib64/python3.10/locale.py", line 620, in setlocale return _setlocale(category, locale) locale.Error: unsupported locale setting >>> Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python3-ansible_2.14.5.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/python/python3-ansible_2.14.5.bb b/recipes-devtools/python/python3-ansible_2.14.5.bb
index ea0fdbe..f3ab237 100644
--- a/recipes-devtools/python/python3-ansible_2.14.5.bb
+++ b/recipes-devtools/python/python3-ansible_2.14.5.bb
@@ -1,7 +1,11 @@
1inherit setuptools3 1inherit setuptools3
2require python-ansible.inc 2require python-ansible.inc
3 3
4RDEPENDS:${PN} += "python3-pyyaml python3-jinja2 python3-modules" 4RDEPENDS:${PN} += "python3-pyyaml \
5 python3-jinja2 \
6 python3-modules \
7 locale-base-en-us \
8"
5 9
6SRC_URI += " \ 10SRC_URI += " \
7 file://python3-ensure-py-scripts-use-py3-for-shebang.patch \ 11 file://python3-ensure-py-scripts-use-py3-for-shebang.patch \