summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-22 10:27:37 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-27 22:44:47 -0400
commitc0e6092f03a3dcffeb01bfa122f8a822f73409b6 (patch)
treeecb76667e7632ff21b0071c29504335d062f7e86
parent257df0d7d6a2c7445f5a4d12094fa9c2a0cf59d3 (diff)
downloadmeta-cloud-services-c0e6092f03a3dcffeb01bfa122f8a822f73409b6.tar.gz
python3-logutils: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-logutils.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb18
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-logutils.inc b/meta-openstack/recipes-devtools/python/python-logutils.inc
deleted file mode 100644
index 87ab631..0000000
--- a/meta-openstack/recipes-devtools/python/python-logutils.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "Set of handlers for the Python standard library's logging package"
2HOMEPAGE = "https://pypi.python.org/pypi/logutils"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44c35f0b8e2a27a2f33a4e4a5c65d014"
6
7SRC_URI[md5sum] = "fcd2f8e9217bfa0b580f253b35a9d954"
8SRC_URI[sha256sum] = "bc058a25d5c209461f134e1f03cab637d66a7a5ccc12e593db56fbb279899a82"
9
10inherit pypi
11
12# avoid "error: option --single-version-externally-managed not recognized"
13DISTUTILS_INSTALL_ARGS = "--root=${D} \
14 --prefix=${prefix} \
15 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
16 --install-data=${datadir}"
diff --git a/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb b/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb
index 4d760e0..c006855 100644
--- a/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb
+++ b/meta-openstack/recipes-devtools/python/python3-logutils_0.3.5.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1DESCRIPTION = "Set of handlers for the Python standard library's logging package"
2require python-logutils.inc 2HOMEPAGE = "https://pypi.python.org/pypi/logutils"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44c35f0b8e2a27a2f33a4e4a5c65d014"
6
7SRC_URI[md5sum] = "fcd2f8e9217bfa0b580f253b35a9d954"
8SRC_URI[sha256sum] = "bc058a25d5c209461f134e1f03cab637d66a7a5ccc12e593db56fbb279899a82"
9
10inherit setuptools3 pypi
11
12# avoid "error: option --single-version-externally-managed not recognized"
13DISTUTILS_INSTALL_ARGS = "--root=${D} \
14 --prefix=${prefix} \
15 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
16 --install-data=${datadir}"