summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-09-07 17:32:09 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:15:42 -0400
commitb9edbfeb513309035c5717ec9a2ded2cabc30eb1 (patch)
tree63f6b6ab5878128ef06144ba96c4005977bf9175
parent1bff130b557dc2217a0a67fd8a336793539ecf8e (diff)
downloadmeta-cloud-services-b9edbfeb513309035c5717ec9a2ded2cabc30eb1.tar.gz
python-nova*: Hack for FILES
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova-compute_2013.1.3.bb24
1 files changed, 20 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova-compute_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-nova-compute_2013.1.3.bb
index 204313d..234ad48 100644
--- a/meta-openstack/recipes-devtools/python/python-nova-compute_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova-compute_2013.1.3.bb
@@ -12,7 +12,7 @@ SRC_URI += "file://nova-compute \
12 12
13inherit compute update-rc.d 13inherit compute update-rc.d
14 14
15PACKAGES = "${SRCNAME}-compute ${SRCNAME}-compute-misc" 15PACKAGES = "${PN} ${SRCNAME}-compute ${SRCNAME}-compute-misc"
16 16
17do_install_append() { 17do_install_append() {
18 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 18 if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
@@ -21,10 +21,26 @@ do_install_append() {
21 fi 21 fi
22} 22}
23 23
24FILES_${SRCNAME}-compute = " ${files_${SRCNAME}-compute}" 24#FILES_${SRCNAME}-compute = " ${files_${SRCNAME}-compute}"
25 25#
26# the controller is built, so we package it out of the way 26# the controller is built, so we package it out of the way
27FILES_${SRCNAME}-compute-misc = "${files_${SRCNAME}-controller} ${files_${SRCNAME}-common} ${files_${PYTHON_PN}}" 27
28#FILES_${SRCNAME}-compute-misc = "${files_${SRCNAME}-controller}
29#${files_${SRCNAME}-common} ${files_${PYTHON_PN}}"
30
31FILES_${PN} = "${libdir}/python*"
32
33FILES_${SRCNAME}-compute = " \
34 ${bindir}/nova-compute \
35 ${sysconfdir}/${SRCNAME}/* \
36 ${sysconfdir}/init.d/nova-compute"
37
38FILES_${SRCNAME}-compute-misc = " \
39 ${bindir} \
40 ${sysconfdir}/init.d/nova-all \
41 ${bindir}/nova-manage \
42 ${bindir}/nova-rootwrap \
43 ${sysconfdir}/sudoers.d"
28 44
29RDEPENDS_${SRCNAME}-compute = "${PYTHON_PN} ${SRCNAME}-common \ 45RDEPENDS_${SRCNAME}-compute = "${PYTHON_PN} ${SRCNAME}-common \
30 qemu libvirt libvirt-libvirtd libvirt-python libvirt-virsh" 46 qemu libvirt libvirt-libvirtd libvirt-python libvirt-virsh"