summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2021-12-20 11:27:06 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-12-20 20:52:01 -0500
commitb770408ae220de81c6c33ca97d3992a41de972f7 (patch)
tree15c6457f0a79201ebd471711e42bfc6f263be366
parentb9d2f911aeb5c70fc6798f0b6aa13199b28a668f (diff)
downloadmeta-cloud-services-b770408ae220de81c6c33ca97d3992a41de972f7.tar.gz
mod-wsgi: move to 4.9.0
Older version of mod-wsgi no longer builds against python 3.10 Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch37
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb4
2 files changed, 20 insertions, 21 deletions
diff --git a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
index 4683db0..79aedff 100644
--- a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
+++ b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
@@ -7,28 +7,31 @@ This allows the recipe to specify specific values instead of them
7being 'discovered' which may lead to host contamination or similar 7being 'discovered' which may lead to host contamination or similar
8issues. 8issues.
9 9
10Updated for 4.9.0: Jeremy Puhlman
11
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11--- 13----
12 configure.ac | 41 +++++++++++++++++++++++++++++++++++++++++ 14 configure.ac | 41 +++++++++++++++++++++++++++++++++++++++++
13 1 file changed, 41 insertions(+) 15 1 file changed, 41 insertions(+)
14 16
17
15diff --git a/configure.ac b/configure.ac 18diff --git a/configure.ac b/configure.ac
16index 25afe44..b5a9e03 100644 19index 37a0f86..9b77c7f 100644
17--- a/configure.ac 20--- a/configure.ac
18+++ b/configure.ac 21+++ b/configure.ac
19@@ -100,26 +100,38 @@ fi 22@@ -106,26 +106,38 @@ fi
20 23
21 AC_SUBST(PYTHON) 24 AC_SUBST(PYTHON)
22 25
23+if test -z "${PYTHON_VERSION}"; then 26+if test -z "${PYTHON_VERSION}"; then
24 PYTHON_VERSION=`${PYTHON} -c 'from sys import stdout; \ 27 PYTHON_VERSION=`${PYTHON} -c 'from sys import stdout; \
25 from distutils import sysconfig; \ 28 import sysconfig; \
26 stdout.write(sysconfig.get_config_var("VERSION"))'` 29 stdout.write(sysconfig.get_config_var("VERSION"))'`
27+fi 30+fi
28 31
29+if test -z "${PYTHON_LDVERSION}"; then 32+if test -z "${PYTHON_LDVERSION}"; then
30 PYTHON_LDVERSION=`${PYTHON} -c 'from sys import stdout; \ 33 PYTHON_LDVERSION=`${PYTHON} -c 'from sys import stdout; \
31 from distutils import sysconfig; \ 34 import sysconfig; \
32 stdout.write(sysconfig.get_config_var("LDVERSION") or "")'` 35 stdout.write(sysconfig.get_config_var("LDVERSION") or "")'`
33+fi 36+fi
34 37
@@ -38,7 +41,7 @@ index 25afe44..b5a9e03 100644
38 41
39+if test -z "${PYTHON_INCLUDEPY}"; then 42+if test -z "${PYTHON_INCLUDEPY}"; then
40 CPPFLAGS1=`${PYTHON} -c 'from sys import stdout; \ 43 CPPFLAGS1=`${PYTHON} -c 'from sys import stdout; \
41 from distutils import sysconfig; \ 44 import sysconfig; \
42 stdout.write("-I" + sysconfig.get_config_var("INCLUDEPY"))'` 45 stdout.write("-I" + sysconfig.get_config_var("INCLUDEPY"))'`
43+else 46+else
44+CPPFLAGS1="${PYTHON_INCLUDEPY}" 47+CPPFLAGS1="${PYTHON_INCLUDEPY}"
@@ -46,7 +49,7 @@ index 25afe44..b5a9e03 100644
46 49
47+if test -z "${PYTHON_CFLAGS}"; then 50+if test -z "${PYTHON_CFLAGS}"; then
48 CPPFLAGS2=`${PYTHON} -c 'from sys import stdout; \ 51 CPPFLAGS2=`${PYTHON} -c 'from sys import stdout; \
49 from distutils import sysconfig; \ 52 import sysconfig; \
50 stdout.write(" ".join(filter(lambda x: x.startswith("-D"), \ 53 stdout.write(" ".join(filter(lambda x: x.startswith("-D"), \
51 sysconfig.get_config_var("CFLAGS").split())))'` 54 sysconfig.get_config_var("CFLAGS").split())))'`
52+else 55+else
@@ -55,13 +58,13 @@ index 25afe44..b5a9e03 100644
55 58
56 if test "${ENABLE_EMBEDDED}" != "yes"; then 59 if test "${ENABLE_EMBEDDED}" != "yes"; then
57 CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED" 60 CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED"
58@@ -131,22 +143,43 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}" 61@@ -137,22 +149,42 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
59 62
60 AC_SUBST(CPPFLAGS) 63 AC_SUBST(CPPFLAGS)
61 64
62+if test -z "${PYTHON_LIBDIR}"; then 65+if test -z "${PYTHON_LIBDIR}"; then
63 PYTHONLIBDIR=`${PYTHON} -c 'from sys import stdout; \ 66 PYTHONLIBDIR=`${PYTHON} -c 'from sys import stdout; \
64 from distutils import sysconfig; \ 67 import sysconfig; \
65 stdout.write(sysconfig.get_config_var("LIBDIR"))'` 68 stdout.write(sysconfig.get_config_var("LIBDIR"))'`
66+else 69+else
67+PYTHONLIBDIR="${PYTHON_LIBDIR}" 70+PYTHONLIBDIR="${PYTHON_LIBDIR}"
@@ -76,22 +79,21 @@ index 25afe44..b5a9e03 100644
76+fi 79+fi
77+if test -z "${PYTHON_FRAMEWORKDIR}"; then 80+if test -z "${PYTHON_FRAMEWORKDIR}"; then
78 PYTHONFRAMEWORKDIR=`${PYTHON} -c 'from sys import stdout; \ 81 PYTHONFRAMEWORKDIR=`${PYTHON} -c 'from sys import stdout; \
79 from distutils import sysconfig; \ 82 import sysconfig; \
80 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKDIR"))'` 83 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKDIR"))'`
81+else 84+else
82+PYTHONFRAMEWORKDIR="${PYTHON_FRAMEWORKDIR}" 85+PYTHONFRAMEWORKDIR="${PYTHON_FRAMEWORKDIR}"
83+fi 86+fi
84+
85+if test -z "${PYTHON_FRAMEWORKPREFIX}"; then 87+if test -z "${PYTHON_FRAMEWORKPREFIX}"; then
86 PYTHONFRAMEWORKPREFIX=`${PYTHON} -c 'from sys import stdout; \ 88 PYTHONFRAMEWORKPREFIX=`${PYTHON} -c 'from sys import stdout; \
87 from distutils import sysconfig; \ 89 import sysconfig; \
88 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKPREFIX"))'` 90 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORKPREFIX"))'`
89+else 91+else
90+PYTHONFRAMEWORKPREFIX="${PYTHON_FRAMEWORKPREFIX}" 92+PYTHONFRAMEWORKPREFIX="${PYTHON_FRAMEWORKPREFIX}"
91+fi 93+fi
92+if test -z "${PYTHON_FRAMEWORK}"; then 94+if test -z "${PYTHON_FRAMEWORK}"; then
93 PYTHONFRAMEWORK=`${PYTHON} -c 'from sys import stdout; \ 95 PYTHONFRAMEWORK=`${PYTHON} -c 'from sys import stdout; \
94 from distutils import sysconfig; \ 96 import sysconfig; \
95 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORK"))'` 97 stdout.write(sysconfig.get_config_var("PYTHONFRAMEWORK"))'`
96+else 98+else
97+PYTHONFRAMEWORK="${PYTHON_FRAMEWORK}" 99+PYTHONFRAMEWORK="${PYTHON_FRAMEWORK}"
@@ -99,20 +101,20 @@ index 25afe44..b5a9e03 100644
99 101
100 if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then 102 if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then
101 PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}" 103 PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}"
102@@ -170,12 +203,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \ 104@@ -180,12 +212,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
103 LDLIBS1="-lpython${PYTHON_VERSION}" 105 LDLIBS1="-lpython${PYTHON_VERSION}"
104 fi 106 fi
105 107
106+ if test -z "${PYTHON_LIBS}"; then 108+ if test -z "${PYTHON_LIBS}"; then
107 LDLIBS2=`${PYTHON} -c 'from sys import stdout; \ 109 LDLIBS2=`${PYTHON} -c 'from sys import stdout; \
108 from distutils import sysconfig; \ 110 import sysconfig; \
109 stdout.write(sysconfig.get_config_var("LIBS"))'` 111 stdout.write(sysconfig.get_config_var("LIBS"))'`
110+ else 112+ else
111+ LDLIBS2="${PYTHON_LIBS}" 113+ LDLIBS2="${PYTHON_LIBS}"
112+ fi 114+ fi
113+ if test -z "${PYTHON_SYSLIBS}"; then 115+ if test -z "${PYTHON_SYSLIBS}"; then
114 LDLIBS3=`${PYTHON} -c 'from sys import stdout; \ 116 LDLIBS3=`${PYTHON} -c 'from sys import stdout; \
115 from distutils import sysconfig; \ 117 import sysconfig; \
116 stdout.write(sysconfig.get_config_var("SYSLIBS"))'` 118 stdout.write(sysconfig.get_config_var("SYSLIBS"))'`
117+ else 119+ else
118+ LDLIBS3="${PYTHON_SYSLIBS}" 120+ LDLIBS3="${PYTHON_SYSLIBS}"
@@ -120,6 +122,3 @@ index 25afe44..b5a9e03 100644
120 else 122 else
121 LDFLAGS1="-Wl,-F${PYTHONFRAMEWORKPREFIX} -framework ${PYTHONFRAMEWORK}" 123 LDFLAGS1="-Wl,-F${PYTHONFRAMEWORKPREFIX} -framework ${PYTHONFRAMEWORK}"
122 124
123--
1242.7.4
125
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
index 79afba8..910bba1 100644
--- a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
+++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
@@ -9,8 +9,8 @@ HOMEPAGE = "https://github.com/GrahamDumpleton/mod_wsgi"
9LICENSE = "Apache-2.0" 9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11 11
12SRCREV = "217e80b7436035723b80ff02ee349365e8553dfc" 12SRCREV = "df9faf954a1ab6208f45ba6fde90f0b41f605483"
13PV = "4.6.8+git${SRCPV}" 13PV = "4.9.0+git${SRCPV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16