summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2021-03-16 14:05:25 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-03-16 08:58:39 -0400
commita878d3aedf0339cf121c0c933d9f3cfb526f56f9 (patch)
tree32448e7de8cccf245616b9cd9b881827c836dac0
parentb45600fc98b1a2f2dbc18418de52930ba2192190 (diff)
downloadmeta-cloud-services-a878d3aedf0339cf121c0c933d9f3cfb526f56f9.tar.gz
consul: export GO111MODULE=off
With the latest go version bump in oe-core export GO111MODULE is on by default. Our build is not setup to use go modules, so we disable it and avoid configuration errors. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-connectivity/consul/consul_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index b96499c..f4955e2 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -28,6 +28,10 @@ COMPATIBLE_HOST_mipsarch = "null"
28SYSTEMD_SERVICE_${PN} = "consul.service" 28SYSTEMD_SERVICE_${PN} = "consul.service"
29SYSTEMD_AUTO_ENABLE_${PN} = "disable" 29SYSTEMD_AUTO_ENABLE_${PN} = "disable"
30 30
31do_compile_prepend () {
32 export GO111MODULE=off
33}
34
31do_install_append() { 35do_install_append() {
32 install -d ${D}/${systemd_unitdir}/system 36 install -d ${D}/${systemd_unitdir}/system
33 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system 37 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system