summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihai Prica <prica.mihai@gmail.com>2013-07-15 13:49:06 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:58 -0400
commit9483378e842c07245ea1a478461621a3930b6c58 (patch)
tree5c5bf8c5226f6249ea1a463f0618917a1f94cd11
parent0fd65f9e27ec189a0e180987a76f2565bf73df41 (diff)
downloadmeta-cloud-services-9483378e842c07245ea1a478461621a3930b6c58.tar.gz
identity.bbclass: Added new class
Each service(nova, glance, cinder...) has its own keystone user. These users are created in a postinstall for the keystone package. This new class is used to store some of the credentials used by keystone and all packages will inherit this class and create the appropriate configuration files. Signed-off-by: Mihai Prica <prica.mihai@gmail.com>
-rw-r--r--meta-openstack/classes/identity.bbclass3
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb6
2 files changed, 7 insertions, 2 deletions
diff --git a/meta-openstack/classes/identity.bbclass b/meta-openstack/classes/identity.bbclass
new file mode 100644
index 0000000..07c8efc
--- /dev/null
+++ b/meta-openstack/classes/identity.bbclass
@@ -0,0 +1,3 @@
1SERVICE_TOKEN = "password"
2SERVICE_PASSWORD = "password"
3SERVICE_TENANT_NAME = "service"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
index fc4b3a0..d6ad46d 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "34347a3242a40d93b98c3722e6f3fbc112bc1c9ef20c045c3d40637e45
19 19
20S = "${WORKDIR}/${SRCNAME}-${PV}" 20S = "${WORKDIR}/${SRCNAME}-${PV}"
21 21
22inherit setuptools update-rc.d 22inherit setuptools update-rc.d identity
23 23
24SERVICE_TOKEN = "password" 24SERVICE_TOKEN = "password"
25 25
@@ -68,7 +68,9 @@ pkg_postinst_${SRCNAME} () {
68 #Create users, services and endpoints 68 #Create users, services and endpoints
69 /etc/init.d/keystone start 69 /etc/init.d/keystone start
70 sleep 0.25 70 sleep 0.25
71 bash /etc/keystone/identity.sh 71 SERVICE_PASSWORD=${SERVICE_PASSWORD} \
72 SERVICE_TENANT_NAME=${SERVICE_TENANT_NAME} \
73 bash /etc/keystone/identity.sh
72} 74}
73 75
74PACKAGES += " ${SRCNAME}" 76PACKAGES += " ${SRCNAME}"