summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-22 11:09:29 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-27 10:39:51 -0500
commit8fdbf26a2b1fc798c10699424199663c036745af (patch)
treee3153e32f3bf68b9e3f1265d26cc851520880345
parentfc1d523aa0f734ec88907f5b4ecc510d8fa56f51 (diff)
downloadmeta-cloud-services-8fdbf26a2b1fc798c10699424199663c036745af.tar.gz
python-django-compressor: set useful perms
Horizon will fail when you attempt to open the login page. The error message will indicate that 'compressor' is not found but the issue is in fact that apache2 can't access these files/directories as they are restricted to 'root' only. Looking at other Linux deployments this change matches the permissions you would find elsewhere and now allows for proper operation. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb b/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
index c546c85..9d528d9 100644
--- a/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
@@ -17,4 +17,11 @@ RDEPENDS_${PN} += " \
17 python-rjsmin \ 17 python-rjsmin \
18 " 18 "
19 19
20do_install_append() {
21 # Ensure permisive perms are granted
22 find -L "${D}${PYTHON_SITEPACKAGES_DIR}/compressor" -type f -exec chmod 644 {} \;
23 find -L "${D}${PYTHON_SITEPACKAGES_DIR}/compressor" -type d -exec chmod 755 {} \;
24}
25
26
20CLEANBROKEN = "1" 27CLEANBROKEN = "1"