summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-12-05 09:43:34 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-06 14:10:45 -0500
commit8c9c30a894d23c50da2b588216ccee794518ce2f (patch)
tree198a6cc7217e0df7b28c4366ee655f6421921891
parent6b73cbe165359eca0739949de51c79ae8c75bb58 (diff)
downloadmeta-cloud-services-8c9c30a894d23c50da2b588216ccee794518ce2f.tar.gz
python-saharaclient: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-saharaclient.inc28
-rw-r--r--meta-openstack/recipes-devtools/python/python-saharaclient_git.bb30
-rw-r--r--meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb2
3 files changed, 31 insertions, 29 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-saharaclient.inc b/meta-openstack/recipes-devtools/python/python-saharaclient.inc
new file mode 100644
index 0000000..91549ae
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-saharaclient.inc
@@ -0,0 +1,28 @@
1DESCRIPTION = "CLI and python client library for OpenStack Sahara"
2HOMEPAGE = "https://launchpad.net/sahara"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 ${PYTHON_PN}-pip \
9 ${PYTHON_PN}-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 ${PYTHON_PN}-pbr-native \
15"
16
17RDEPENDS_${PN} += " \
18 ${PYTHON_PN}-pbr \
19 "
20
21SRCNAME = "saharaclient"
22
23SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
24
25PV = "2.3.0+git${SRCPV}"
26SRCREV = "3107b452467537f4eef3d9ecfb5e35d110d19662"
27S = "${WORKDIR}/git"
28
diff --git a/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb b/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb
index 0d571c9..4b9587f 100644
--- a/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb
@@ -1,30 +1,2 @@
1DESCRIPTION = "CLI and python client library for OpenStack Sahara" 1require python-saharaclient.inc
2HOMEPAGE = "https://launchpad.net/sahara"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15"
16
17RDEPENDS_${PN} += " \
18 python-pbr \
19 "
20
21SRCNAME = "saharaclient"
22
23SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
24
25PV = "2.3.0+git${SRCPV}"
26SRCREV = "3107b452467537f4eef3d9ecfb5e35d110d19662"
27S = "${WORKDIR}/git"
28
29inherit setuptools 2inherit setuptools
30
diff --git a/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb b/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb
new file mode 100644
index 0000000..806cd76
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb
@@ -0,0 +1,2 @@
1require python-saharaclient.inc
2inherit setuptools3