summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-09-02 11:23:32 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-03 15:51:05 -0400
commit87749f4fa0cb46739aae385718d62fd77738d66f (patch)
tree91a8334ba51c27959e0d3ecd7f853b96db36505e
parentfe617758d47cd586985c08fe5424f208575eec68 (diff)
downloadmeta-cloud-services-87749f4fa0cb46739aae385718d62fd77738d66f.tar.gz
python-positional: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-positional.inc21
-rw-r--r--meta-openstack/recipes-devtools/python/python-positional_1.2.1.bb23
-rw-r--r--meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb2
3 files changed, 25 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-positional.inc b/meta-openstack/recipes-devtools/python/python-positional.inc
new file mode 100644
index 0000000..736e691
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-positional.inc
@@ -0,0 +1,21 @@
1DESCRIPTION = "Library to enforce positional or key-word arguments"
2HOMEPAGE = "https://github.com/morganfainberg/positional"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
6
7SRC_URI[md5sum] = "4afcffd8e2ba733fd7a50f137a2ee893"
8SRC_URI[sha256sum] = "cf48ea169f6c39486d5efa0ce7126a97bed979a52af6261cf255a41f9a74453a"
9
10inherit pypi
11
12CLEANBROKEN = "1"
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 ${PYTHON_PN}-pbr-native \
17 "
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-wrapt \
21"
diff --git a/meta-openstack/recipes-devtools/python/python-positional_1.2.1.bb b/meta-openstack/recipes-devtools/python/python-positional_1.2.1.bb
index 93eb6e1..14f0187 100644
--- a/meta-openstack/recipes-devtools/python/python-positional_1.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-positional_1.2.1.bb
@@ -1,21 +1,2 @@
1DESCRIPTION = "Library to enforce positional or key-word arguments" 1inherit setuptools
2HOMEPAGE = "https://github.com/morganfainberg/positional" 2require python-positional.inc
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
6
7SRC_URI[md5sum] = "4afcffd8e2ba733fd7a50f137a2ee893"
8SRC_URI[sha256sum] = "cf48ea169f6c39486d5efa0ce7126a97bed979a52af6261cf255a41f9a74453a"
9
10inherit setuptools pypi
11
12CLEANBROKEN = "1"
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 python-pbr-native \
17 "
18
19RDEPENDS_${PN} += " \
20 python-wrapt \
21"
diff --git a/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb b/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
new file mode 100644
index 0000000..3081cd2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-positional.inc