summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-07-28 08:44:57 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-30 15:45:58 -0400
commit74d5d04744038e26851fc06bb29daecd3b1ec2b8 (patch)
tree85b9601313082613548128067c5556f807993f94
parent3ec390aef340c32ac0f52e1c6aa38da522e5fd68 (diff)
downloadmeta-cloud-services-74d5d04744038e26851fc06bb29daecd3b1ec2b8.tar.gz
python3-keystonemiddleware: Change python to python3
Version updated to 4.17.1 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb44
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keystonemiddleware_git.bb44
2 files changed, 44 insertions, 44 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
deleted file mode 100644
index c730906..0000000
--- a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1DESCRIPTION = "Middleware for OpenStack Identity API"
2HOMEPAGE = "https://launchpad.net/keystonemiddleware"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6
7SRCNAME = "keystonemiddleware"
8
9SRC_URI = "\
10 git://git.openstack.org/openstack/keystonemiddleware;branch=stable/pike \
11 "
12
13PV = "4.17.0+git${SRCPV}"
14SRCREV = "69aed2693475797c8d0dda2725a790eea05a9419"
15S = "${WORKDIR}/git"
16
17inherit setuptools3
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 python-pbr-native \
27 "
28
29RDEPENDS_${PN} += " \
30 python-keystoneauth1 \
31 python-oslo.config \
32 python-oslo.context \
33 python-oslo.i18n \
34 python-oslo.log \
35 python-oslo.serialization \
36 python-oslo.utils \
37 python-pbr \
38 python-positional \
39 python-pycadf \
40 python-keystoneclient \
41 python-requests \
42 python-six \
43 python-webob \
44 "
diff --git a/meta-openstack/recipes-devtools/python/python3-keystonemiddleware_git.bb b/meta-openstack/recipes-devtools/python/python3-keystonemiddleware_git.bb
new file mode 100644
index 0000000..b9f0f79
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-keystonemiddleware_git.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Middleware for OpenStack Identity API"
2HOMEPAGE = "https://launchpad.net/keystonemiddleware"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6
7SRCNAME = "keystonemiddleware"
8
9SRC_URI = "\
10 git://git.openstack.org/openstack/keystonemiddleware;branch=stable/pike \
11 "
12
13PV = "4.17.1+git${SRCPV}"
14SRCREV = "6712e8b7125fcbcf891b7e89ecb240798dad28ac"
15S = "${WORKDIR}/git"
16
17inherit setuptools3
18
19DEPENDS += " \
20 python3-pip \
21 python3-pbr \
22 "
23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 python3-pbr-native \
27 "
28
29RDEPENDS_${PN} += " \
30 python3-keystoneauth1 \
31 python3-oslo.config \
32 python3-oslo.context \
33 python3-oslo.i18n \
34 python3-oslo.log \
35 python3-oslo.serialization \
36 python3-oslo.utils \
37 python3-pbr \
38 python3-positional \
39 python3-pycadf \
40 python3-keystoneclient \
41 python3-requests \
42 python3-six \
43 python3-webob \
44 "