summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnne Macedo <retpolanne@posteo.net>2023-08-26 17:28:23 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-08-27 13:36:03 +0000
commit6e2678156d9a1da7788543833686f03874fd2709 (patch)
treed3a3934027cb083e73a42f0bb869eeee2c750833
parent7ecb54163f6252cfbecfd9f7f363536c88dbb58a (diff)
downloadmeta-cloud-services-6e2678156d9a1da7788543833686f03874fd2709.tar.gz
consul: fixes consul git urls
Fixes error: URL: git://github.com/hashicorp/consul-migrate.git;branch=master uses git protocol which is no longer supported by github. Please change to ;protocol=https in the url. when running bitbake with the meta-cloud-services layer. Signed-off-by: Anne Macedo <retpolanne@posteo.net> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-connectivity/consul/consul-migrate_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-connectivity/consul/consul-migrate_git.bb b/recipes-connectivity/consul/consul-migrate_git.bb
index 7d784c2..1393c91 100644
--- a/recipes-connectivity/consul/consul-migrate_git.bb
+++ b/recipes-connectivity/consul/consul-migrate_git.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD & MPL-2.0 & MIT"
4LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul-migrate/LICENSE;md5=b278a92d2c1509760384428817710378" 4LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul-migrate/LICENSE;md5=b278a92d2c1509760384428817710378"
5 5
6GO_IMPORT = "github.com/hashicorp/consul-migrate" 6GO_IMPORT = "github.com/hashicorp/consul-migrate"
7SRC_URI = "git://${GO_IMPORT}.git;branch=master" 7SRC_URI = "https://${GO_IMPORT}.git;branch=master"
8SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710" 8SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
@@ -18,13 +18,13 @@ SRCREV_bolt = "c6ba97b89e0454fec9aa92e1d33a4e2c5fc1f631"
18SRCREV_go-msgpack = "fa3f63826f7c23912c15263591e65d54d080b458" 18SRCREV_go-msgpack = "fa3f63826f7c23912c15263591e65d54d080b458"
19 19
20SRC_URI += " \ 20SRC_URI += " \
21 git://github.com/hashicorp/raft;name=raft;destsuffix=git/src/github.com/hashicorp/raft;branch=master;protocol=https \ 21 https://github.com/hashicorp/raft;name=raft;destsuffix=git/src/github.com/hashicorp/raft;branch=master;protocol=https \
22 git://github.com/armon/go-metrics;name=go-metrics;destsuffix=git/src/github.com/armon/go-metrics;branch=master;protocol=https \ 22 https://github.com/armon/go-metrics;name=go-metrics;destsuffix=git/src/github.com/armon/go-metrics;branch=master;protocol=https \
23 git://github.com/hashicorp/raft-boltdb;name=raft-boltdb;destsuffix=git/src/github.com/hashicorp/raft-boltdb;branch=master;protocol=https \ 23 https://github.com/hashicorp/raft-boltdb;name=raft-boltdb;destsuffix=git/src/github.com/hashicorp/raft-boltdb;branch=master;protocol=https \
24 git://github.com/hashicorp/raft-mdb;name=raft-mdb;destsuffix=git/src/github.com/hashicorp/raft-mdb;branch=master;protocol=https \ 24 https://github.com/hashicorp/raft-mdb;name=raft-mdb;destsuffix=git/src/github.com/hashicorp/raft-mdb;branch=master;protocol=https \
25 git://github.com/armon/gomdb;name=gomdb;destsuffix=git/src/github.com/armon/gomdb;branch=master;protocol=https \ 25 https://github.com/armon/gomdb;name=gomdb;destsuffix=git/src/github.com/armon/gomdb;branch=master;protocol=https \
26 git://github.com/boltdb/bolt;name=bolt;destsuffix=git/src/github.com/boltdb/bolt;branch=master;protocol=https \ 26 https://github.com/boltdb/bolt;name=bolt;destsuffix=git/src/github.com/boltdb/bolt;branch=master;protocol=https \
27 git://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack;branch=master;protocol=https \ 27 https://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack;branch=master;protocol=https \
28" 28"
29 29
30inherit go 30inherit go