summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-12-01 15:19:38 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-12-01 21:46:36 -0500
commit6802a4f90ebdb8b1eecb777b2b8634dda7df18fd (patch)
treea30f1ae0902604a8e71d5f4d536cdc03d5b5d9b2
parent9ff65ecfdc232eda192c1ca2f79a99a61121737a (diff)
downloadmeta-cloud-services-6802a4f90ebdb8b1eecb777b2b8634dda7df18fd.tar.gz
python-cursive: initial version using stable/pike
This package is required by python-glance. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cursive_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cursive_git.bb b/meta-openstack/recipes-devtools/python/python-cursive_git.bb
new file mode 100644
index 0000000..1a677f1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cursive_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Library for validation of digital signatures."
2HOMEPAGE = "https://github.com/openstack/cursive"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://git.openstack.org/openstack/cursive.git;branch=master \
9 "
10
11PV="0.2.0+git${SRCPV}"
12SRCREV="ad25a4016c56eeceb85764c7ac4501def2b5445a"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-lxml \
24 python-cryptography \
25 python-netifaces \
26 python-six \
27 python-oslo.serialization \
28 python-oslo.utils \
29 python-oslo.i18n \
30 python-oslo.log \
31 python-castellan \
32 "