summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-11-10 14:47:40 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-14 23:18:08 -0500
commit61b50885bff0287816c7428005f9e349e7c44e0c (patch)
treed42654ab8ca824d71c2428defaf8ad59c2d55857
parent3ab396210e8c9dc8cfd40ba169bbc2cd35557f17 (diff)
downloadmeta-cloud-services-61b50885bff0287816c7428005f9e349e7c44e0c.tar.gz
python3-routes: upgrade 2.4.1 -> 2.5.1
Consolidate inc and bb files into a single bb file. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-routes.inc15
-rw-r--r--meta-openstack/recipes-devtools/python/python3-routes_2.5.1.bb17
-rw-r--r--meta-openstack/recipes-devtools/python/python3-routes_git.bb2
3 files changed, 17 insertions, 17 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-routes.inc b/meta-openstack/recipes-devtools/python/python-routes.inc
deleted file mode 100644
index 4224552..0000000
--- a/meta-openstack/recipes-devtools/python/python-routes.inc
+++ /dev/null
@@ -1,15 +0,0 @@
1DESCRIPTION = "A Python re-implementation of the Rails routes system."
2HOMEPAGE = "http://routes.groovie.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=90976c1a0e3029278f882cfe2e84a6ae"
6
7PV = "2.4.1+git${SRCPV}"
8SRCREV = "2dcef8079cf09f427eeb0be62374f6c1a52bf59d"
9
10SRCNAME = "Routes"
11SRC_URI = "git://github.com/bbangert/routes.git"
12
13S = "${WORKDIR}/git"
14
15RDEPENDS_${PN} += "${PYTHON_PN}-repoze.lru"
diff --git a/meta-openstack/recipes-devtools/python/python3-routes_2.5.1.bb b/meta-openstack/recipes-devtools/python/python3-routes_2.5.1.bb
new file mode 100644
index 0000000..309bb29
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-routes_2.5.1.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "A Python re-implementation of the Rails routes system."
2HOMEPAGE = "http://routes.groovie.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=90976c1a0e3029278f882cfe2e84a6ae"
6
7SRC_URI[sha256sum] = "b6346459a15f0cbab01a45a90c3d25caf980d4733d628b4cc1952b865125d053"
8
9PYPI_PACKAGE = "Routes"
10
11inherit setuptools3 pypi
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-netclient \
15 ${PYTHON_PN}-six \
16 ${PYTHON_PN}-repoze.lru \
17"
diff --git a/meta-openstack/recipes-devtools/python/python3-routes_git.bb b/meta-openstack/recipes-devtools/python/python3-routes_git.bb
deleted file mode 100644
index 06dd1ad..0000000
--- a/meta-openstack/recipes-devtools/python/python3-routes_git.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1inherit setuptools3
2require python-routes.inc