summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihai Prica <prica.mihai@gmail.com>2013-07-17 11:52:43 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:59 -0400
commit6188d4a09af283a5db6b2a5089168463e38b16fd (patch)
treec342efbd3dc0436a6c13edb99de4e63adea455ae
parent0b390076b90d934ac5b57da2e2fe429182a9754b (diff)
downloadmeta-cloud-services-6188d4a09af283a5db6b2a5089168463e38b16fd.tar.gz
identity: Set ADMIN_PASSWORD from identity class
Signed-off-by: Mihai Prica <prica.mihai@gmail.com>
-rw-r--r--meta-openstack/classes/identity.bbclass1
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb4
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-openstack/classes/identity.bbclass b/meta-openstack/classes/identity.bbclass
index b86eb76..d1eb276 100644
--- a/meta-openstack/classes/identity.bbclass
+++ b/meta-openstack/classes/identity.bbclass
@@ -1,4 +1,5 @@
1SERVICE_TOKEN = "password" 1SERVICE_TOKEN = "password"
2ADMIN_PASSWORD = "password"
2SERVICE_PASSWORD = "password" 3SERVICE_PASSWORD = "password"
3SERVICE_TENANT_NAME = "service" 4SERVICE_TENANT_NAME = "service"
4DB_USER = "admin" 5DB_USER = "admin"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
index 216bfd2..1c6e804 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.bb
@@ -62,11 +62,11 @@ pkg_postinst_${SRCNAME} () {
62 sudo -u postgres createdb keystone 62 sudo -u postgres createdb keystone
63 keystone-manage db_sync 63 keystone-manage db_sync
64 keystone-manage pki_setup 64 keystone-manage pki_setup
65 # quick fix 65
66 echo "source /etc/keystone/openrc" > /home/root/.bashrc
67 #Create users, services and endpoints 66 #Create users, services and endpoints
68 /etc/init.d/keystone start 67 /etc/init.d/keystone start
69 sleep 0.25 68 sleep 0.25
69 ADMIN_PASSWORD=${ADMIN_PASSWORD} \
70 SERVICE_PASSWORD=${SERVICE_PASSWORD} \ 70 SERVICE_PASSWORD=${SERVICE_PASSWORD} \
71 SERVICE_TENANT_NAME=${SERVICE_TENANT_NAME} \ 71 SERVICE_TENANT_NAME=${SERVICE_TENANT_NAME} \
72 bash /etc/keystone/identity.sh 72 bash /etc/keystone/identity.sh