summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-10-30 15:23:18 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-10-30 16:55:03 -0400
commit6002b1f81eaac75ea96401ad36ea6178981dd268 (patch)
tree55e674810c464e087b18695cafb2013a91ea90e1
parent9b2760a552ede25617e2a67b4f2e9c4cd3972cfa (diff)
downloadmeta-cloud-services-6002b1f81eaac75ea96401ad36ea6178981dd268.tar.gz
keystone: add missing functools32 module
Keystone fails to install due to functools32 missing. Add a new recipe for functools32 and include the dependency in keystone. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-functools32_3.2.3-2.bb29
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-functools32_3.2.3-2.bb b/meta-openstack/recipes-devtools/python/python-functools32_3.2.3-2.bb
new file mode 100644
index 0000000..937e933
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-functools32_3.2.3-2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Python higher-order functions and operations on callable objects"
2HOMEPAGE = "https://pypi.python.org/pypi/functools32"
3SECTION = "devel/python"
4LICENSE = "PSFv2"
5
6SRCNAME = "functools32"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=27cf2345969ed18e6730e90fb0063a10"
9SRC_URI = "http://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10SRC_URI[md5sum] = "09f24ffd9af9f6cd0f63cb9f4e23d4b2"
11SRC_URI[sha256sum] = "f6253dfbe0538ad2e387bd8fdfd9293c925d63553f5813c4e587745416501e6d"
12
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15inherit distutils
16
17DISTUTILS_INSTALL_ARGS = "--root=${D} \
18 --prefix=${prefix} \
19 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
20 --install-data=${datadir}"
21
22DEPENDS += " \
23 python-pbr \
24 "
25
26RDEPENDS_${PN} += "python-testtools \
27 python-pbr \
28 "
29
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 8fbf996..58aa449 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -286,6 +286,7 @@ RDEPENDS_${PN} += " \
286 python-oauthlib \ 286 python-oauthlib \
287 python-fixtures \ 287 python-fixtures \
288 python-oslotest \ 288 python-oslotest \
289 python-functools32 \
289 " 290 "
290 291
291RDEPENDS_${SRCNAME}-tests += " bash" 292RDEPENDS_${SRCNAME}-tests += " bash"